Remove placeholders and cleanup spec
[platform/core/api/runtime-info.git] / packaging / capi-system-runtime-info.spec
1 Name:       capi-system-runtime-info
2 Summary:    A Runtime Information library in Tizen Native API
3 Version:    0.0.3
4 Release:    0
5 Group:      System/API
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(dlog)
10 BuildRequires:  pkgconfig(vconf)
11 BuildRequires:  pkgconfig(capi-base-common)
12
13 %description
14 A Runtime Information library in Tizen Native API.
15
16 %package devel
17 Summary:  A Runtime Information library in Tizen Native API (Development)
18 Group:    Development/System
19 Requires: %{name} = %{version}-%{release}
20 Requires:  pkgconfig(capi-base-common)
21
22 %description devel
23 %devel_desc
24
25
26
27 %prep
28 %setup -q
29
30
31 %build
32 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`  
33 %cmake . -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
34
35
36 make %{?jobs:-j%jobs}
37
38 %install
39 %make_install
40
41 %post -p /sbin/ldconfig
42
43 %postun -p /sbin/ldconfig
44
45
46 %files
47 %license LICENSE.APLv2
48 %{_libdir}/lib*.so.*
49 %manifest runtime-info.manifest
50
51 %files devel
52 %{_includedir}/system/*.h
53 %{_libdir}/pkgconfig/*.pc
54 %{_libdir}/lib*.so
55
56