resetting manifest requested domain to floor
[platform/core/api/power.git] / packaging / capi-system-power.spec
1 Name:       capi-system-power
2 Summary:    A power library in SLP C API
3 Version:    0.1.1
4 Release:    1
5 Group:      System/API
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source1001:     capi-system-power.manifest
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(dlog)
11 BuildRequires:  pkgconfig(pmapi)
12 BuildRequires:  pkgconfig(glib-2.0)
13 BuildRequires:  pkgconfig(capi-base-common)
14 BuildRequires:  pkgconfig(vconf)
15
16 %description
17
18 %package devel
19 Summary:  A power library in SLP C API (Development)
20 Group:    Development/System
21 Requires: %{name} = %{version}-%{release}
22
23 %description devel
24 %devel_desc
25
26 %prep
27 %setup -q
28
29 %build
30 cp %{SOURCE1001} .
31 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
32 %cmake . -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
33
34
35 make %{?jobs:-j%jobs}
36
37 %install
38 %make_install
39
40 %post -p /sbin/ldconfig
41
42 %postun -p /sbin/ldconfig
43
44
45 %files
46 %manifest %{name}.manifest
47 %license LICENSE.APLv2
48 %manifest capi-system-power.manifest
49 %{_libdir}/libcapi-system-power.so.*
50
51 %files devel
52 %manifest %{name}.manifest
53 %{_includedir}/system/power.h
54 %{_libdir}/pkgconfig/*.pc
55 %{_libdir}/libcapi-system-power.so
56
57