3ae13dfc0d7bf1d3c506751939db4a12a7d450a7
[platform/core/api/device.git] / packaging / capi-system-device.spec
1 Name:       capi-system-device
2 Summary:    A Device library in TIZEN C API
3 Version:    0.1.0
4 Release:    0
5 Group:      System/API
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source1:    capi-system-device.manifest
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(capi-base-common)
11 BuildRequires:  pkgconfig(capi-system-info)
12 BuildRequires:  pkgconfig(dlog)
13 BuildRequires:  pkgconfig(vconf)
14 BuildRequires:  pkgconfig(gio-2.0)
15 BuildRequires:  pkgconfig(tracker)
16
17 %description
18 A Device library in TIZEN C API package.
19
20 %package devel
21 Summary:  A Device library in TIZEN C API (Development)
22 Group:    System/Development
23 Requires: %{name} = %{version}-%{release}
24
25 %description devel
26 A Device library in TIZEN C API (Development) package.
27 %devel_desc
28
29 %prep
30 %setup -q
31
32 %build
33 cp %{SOURCE1} .
34 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
35 %cmake . -DFULLVER=%{version} \
36                  -DMAJORVER=${MAJORVER}
37
38 %__make %{?jobs:-j%jobs}
39
40 %install
41 %make_install
42
43 %post -p /sbin/ldconfig
44
45 %postun -p /sbin/ldconfig
46
47 %files
48 %manifest %{name}.manifest
49 %license LICENSE.Apache-2.0
50 %{_libdir}/libcapi-system-device.so.*
51 /etc/deviced/device/*.conf
52
53 %files devel
54 %manifest %{name}.manifest
55 %license LICENSE.Apache-2.0
56 %{_includedir}/device/*.h
57 %{_includedir}/system/*.h
58 %{_libdir}/pkgconfig/*.pc
59 %{_libdir}/libcapi-system-device.so