Modified get/set passphrase functions
[platform/core/api/tethering.git] / packaging / capi-network-tethering.spec
1 Name:           capi-network-tethering
2 Summary:        Tethering Framework
3 Version:        1.0.23
4 Release:        1
5 Group:          System/Network
6 License:        Apache-2.0
7 Source0:        %{name}-%{version}.tar.gz
8 BuildRequires:  pkgconfig(dlog)
9 BuildRequires:  pkgconfig(dbus-1)
10 BuildRequires:  pkgconfig(capi-base-common)
11 BuildRequires:  pkgconfig(glib-2.0)
12 BuildRequires:  pkgconfig(gio-2.0)
13 BuildRequires:  pkgconfig(vconf)
14 BuildRequires:  pkgconfig(key-manager)
15 BuildRequires:  pkgconfig(libssl)
16 BuildRequires:  pkgconfig(capi-system-info)
17 BuildRequires:  cmake
18 Requires(post):         /sbin/ldconfig
19 Requires(postun):       /sbin/ldconfig
20
21 %description
22 Tethering framework library for CAPI
23
24 %package devel
25 Summary:        Development package for Tethering framework library
26 Group:          Development/Libraries
27 Requires:       %{name} = %{version}-%{release}
28 %description devel
29 Development package for Tethering framework library
30
31 %prep
32 %setup -q
33
34
35 %build
36 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
37 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
38 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
39
40 %cmake -DCMAKE_BUILD_TYPE="Private" \
41 %if "%{?profile}" == "wearable"
42         -DTIZEN_WEARABLE=1 \
43 %else
44 %if "%{?profile}" == "mobile"
45         -DTIZEN_MOBILE=1 \
46 %endif
47 %endif
48 %ifarch %{arm}
49         -DCMAKE_BUILD_TYPE="Private" -DARCH=arm \
50 %else
51 %if 0%{?simulator}
52         -DCMAKE_BUILD_TYPE="Private" -DARCH=emul \
53 %else
54         -DCMAKE_BUILD_TYPE="Private" -DARCH=i586 \
55 %endif
56 %endif
57         .
58
59 make %{?_smp_mflags}
60
61
62 %install
63 %make_install
64
65 mkdir -p %{buildroot}/usr/share/license
66 cp LICENSE.APLv2.0 %{buildroot}/usr/share/license/capi-network-tethering
67 cp LICENSE.APLv2.0 %{buildroot}/usr/share/license/capi-network-tethering-devel
68
69 %post -p /sbin/ldconfig
70
71 %postun -p /sbin/ldconfig
72
73 %files
74 %manifest capi-network-tethering.manifest
75 %defattr(-,root,root,-)
76 %{_libdir}/*.so.*
77 /usr/share/license/capi-network-tethering
78 %{_bindir}/tethering_test
79 %ifarch %{arm}
80 /etc/config/connectivity/sysinfo-tethering.xml
81 %else
82 %if 0%{?simulator}
83 # Noop
84 %else
85 /etc/config/connectivity/sysinfo-tethering.xml
86 %endif
87 %endif
88
89 %files devel
90 %defattr(-,root,root,-)
91 %{_includedir}/network/*.h
92 %{_libdir}/pkgconfig/*.pc
93 %{_libdir}/*.so
94 /usr/share/license/capi-network-tethering-devel