Remove unnecessary openssl dependency
[platform/core/api/tethering.git] / packaging / capi-network-tethering.spec
1 Name:           capi-network-tethering
2 Summary:        Tethering Framework
3 Version:        1.0.57
4 Release:        1
5 Group:          System/Network
6 License:        Apache-2.0
7 Source0:        %{name}-%{version}.tar.gz
8 BuildRequires:  pkgconfig(dlog)
9 BuildRequires:  pkgconfig(dbus-1)
10 BuildRequires:  pkgconfig(capi-base-common)
11 BuildRequires:  pkgconfig(glib-2.0)
12 BuildRequires:  pkgconfig(gio-2.0)
13 BuildRequires:  pkgconfig(vconf)
14 BuildRequires:  pkgconfig(key-manager)
15 BuildRequires:  pkgconfig(capi-system-info)
16 BuildRequires:  pkgconfig(libtzplatform-config)
17 BuildRequires:  cmake
18 Requires(post):         /sbin/ldconfig
19 Requires(postun):       /sbin/ldconfig
20
21 %description
22 Tethering framework library for CAPI
23
24 %package devel
25 Summary:        Development package for Tethering framework library
26 Group:          Development/Libraries
27 Requires:       %{name} = %{version}-%{release}
28 %description devel
29 Development package for Tethering framework library
30
31 %package tool
32 Summary:        Test application for Tethering
33 %description tool
34 Test application for Tethering
35
36
37 %prep
38 %setup -q
39
40
41 %build
42 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
43 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
44 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
45
46 %cmake .
47
48 make %{?_smp_mflags}
49
50
51 %install
52 %make_install
53
54 %post -p /sbin/ldconfig
55
56 %postun -p /sbin/ldconfig
57
58 %files
59 %manifest capi-network-tethering.manifest
60 %defattr(-,root,root,-)
61 %{_libdir}/*.so.*
62 %license LICENSE
63
64 %files devel
65 %defattr(-,root,root,-)
66 %{_includedir}/network/*.h
67 %{_libdir}/pkgconfig/*.pc
68 %{_libdir}/*.so
69 %license LICENSE
70
71 %files tool
72 %{_bindir}/tethering_test