Add API detail for Wi-Fi set/get tethering txpower.
[platform/core/api/tethering.git] / packaging / capi-network-tethering.spec
1 Name:           capi-network-tethering
2 Summary:        Tethering Framework
3 Version:        1.0.37
4 Release:        1
5 Group:          System/Network
6 License:        Apache-2.0
7 Source0:        %{name}-%{version}.tar.gz
8 BuildRequires:  pkgconfig(dlog)
9 BuildRequires:  pkgconfig(dbus-1)
10 BuildRequires:  pkgconfig(capi-base-common)
11 BuildRequires:  pkgconfig(glib-2.0)
12 BuildRequires:  pkgconfig(gio-2.0)
13 BuildRequires:  pkgconfig(vconf)
14 BuildRequires:  pkgconfig(key-manager)
15 BuildRequires:  pkgconfig(libssl)
16 BuildRequires:  pkgconfig(capi-system-info)
17 BuildRequires:  pkgconfig(libtzplatform-config)
18 BuildRequires:  cmake
19 Requires(post):         /sbin/ldconfig
20 Requires(postun):       /sbin/ldconfig
21
22 %description
23 Tethering framework library for CAPI
24
25 %package devel
26 Summary:        Development package for Tethering framework library
27 Group:          Development/Libraries
28 Requires:       %{name} = %{version}-%{release}
29 %description devel
30 Development package for Tethering framework library
31
32 %prep
33 %setup -q
34
35
36 %build
37 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
38 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
39 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
40
41 %cmake -DCMAKE_BUILD_TYPE="Private" \
42 %if "%{?profile}" == "wearable"
43         -DTIZEN_WEARABLE=1 \
44 %else
45 %if "%{?profile}" == "mobile"
46         -DTIZEN_MOBILE=1 \
47 %endif
48 %endif
49 %ifarch %{arm}
50         -DCMAKE_BUILD_TYPE="Private" -DARCH=arm \
51 %else
52 %if 0%{?simulator}
53         -DCMAKE_BUILD_TYPE="Private" -DARCH=emul \
54 %else
55         -DCMAKE_BUILD_TYPE="Private" -DARCH=i586 \
56 %endif
57 %endif
58         .
59
60 make %{?_smp_mflags}
61
62
63 %install
64 %make_install
65
66 mkdir -p %{buildroot}/usr/share/license
67 cp LICENSE.APLv2.0 %{buildroot}/usr/share/license/capi-network-tethering
68 cp LICENSE.APLv2.0 %{buildroot}/usr/share/license/capi-network-tethering-devel
69
70 %post -p /sbin/ldconfig
71
72 %postun -p /sbin/ldconfig
73
74 %files
75 %manifest capi-network-tethering.manifest
76 %defattr(-,root,root,-)
77 %{_libdir}/*.so.*
78 /usr/share/license/capi-network-tethering
79 %{_bindir}/tethering_test
80 %ifarch %{arm}
81 /etc/config/connectivity/sysinfo-tethering.xml
82 %else
83 %if 0%{?simulator}
84 # Noop
85 %else
86 /etc/config/connectivity/sysinfo-tethering.xml
87 %endif
88 %endif
89
90 %files devel
91 %defattr(-,root,root,-)
92 %{_includedir}/network/*.h
93 %{_libdir}/pkgconfig/*.pc
94 %{_libdir}/*.so
95 /usr/share/license/capi-network-tethering-devel