Merge "Added support of SAE security mode." into tizen
[platform/core/api/tethering.git] / packaging / capi-network-tethering.spec
1 Name:           capi-network-tethering
2 Summary:        Tethering Framework
3 Version:        1.0.57
4 Release:        1
5 Group:          System/Network
6 License:        Apache-2.0
7 Source0:        %{name}-%{version}.tar.gz
8 BuildRequires:  pkgconfig(dlog)
9 BuildRequires:  pkgconfig(dbus-1)
10 BuildRequires:  pkgconfig(capi-base-common)
11 BuildRequires:  pkgconfig(glib-2.0)
12 BuildRequires:  pkgconfig(gio-2.0)
13 BuildRequires:  pkgconfig(vconf)
14 BuildRequires:  pkgconfig(key-manager)
15 BuildRequires:  pkgconfig(capi-system-info)
16 BuildRequires:  pkgconfig(libtzplatform-config)
17 BuildRequires:  cmake
18 %if 0%{?gcov:1}
19 BuildRequires: lcov
20 %endif
21 Requires(post):         /sbin/ldconfig
22 Requires(postun):       /sbin/ldconfig
23
24 %description
25 Tethering framework library for CAPI
26
27 %package devel
28 Summary:        Development package for Tethering framework library
29 Group:          Development/Libraries
30 Requires:       %{name} = %{version}-%{release}
31 %description devel
32 Development package for Tethering framework library
33
34 %package tool
35 Summary:        Test application for Tethering
36 %description tool
37 Test application for Tethering
38
39 %if 0%{?gcov:1}
40 %package gcov
41 Summary:  Tethering Library(gcov)
42 Group:    Network/Testing
43 %description gcov
44 gcov objects for coverage test
45 %endif
46
47 %prep
48 %setup -q
49
50
51 %build
52 %if 0%{?gcov:1}
53 export CFLAGS+=" -fprofile-arcs -ftest-coverage"
54 export CXXFLAGS+=" -fprofile-arcs -ftest-coverage"
55 export FFLAGS+=" -fprofile-arcs -ftest-coverage"
56 export LDFLAGS+=" -lgcov"
57 %endif
58
59 %cmake .
60
61 make %{?_smp_mflags}
62
63 %if 0%{?gcov:1}
64 mkdir -p gcov-obj
65 find . -name '*.gcno' ! -iname "*client*" ! -name "*test*" -exec cp '{}' gcov-obj ';'
66 %endif
67
68 %install
69 %make_install
70 %make_install
71 %if 0%{?gcov:1}
72 mkdir -p %{buildroot}%{_datadir}/gcov/obj
73 install -m 0644 gcov-obj/* %{buildroot}%{_datadir}/gcov/obj
74 %endif
75
76 %post -p /sbin/ldconfig
77
78 %postun -p /sbin/ldconfig
79
80 %files
81 %manifest capi-network-tethering.manifest
82 %defattr(-,root,root,-)
83 %{_libdir}/*.so.*
84 %license LICENSE
85
86 %files devel
87 %defattr(-,root,root,-)
88 %{_includedir}/network/*.h
89 %{_libdir}/pkgconfig/*.pc
90 %{_libdir}/*.so
91 %license LICENSE
92
93 %files tool
94 %{_bindir}/tethering_test
95
96 %if 0%{?gcov:1}
97 %files gcov
98 %{_datadir}/gcov/obj/*
99 %endif