Below changes are applied
[platform/core/api/tethering.git] / packaging / capi-network-tethering.spec
1 Name:       capi-network-tethering
2 Summary:    Tethering Framework
3 Version:    0.0.13
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Requires(post):   /sbin/ldconfig
9 Requires(postun): /sbin/ldconfig
10
11 BuildRequires: pkgconfig(dlog)
12 BuildRequires: pkgconfig(dbus-glib-1)
13 BuildRequires: pkgconfig(capi-base-common)
14 BuildRequires: pkgconfig(glib-2.0)
15 BuildRequires: pkgconfig(vconf)
16 BuildRequires: cmake
17
18 %description
19 Tethering framework library for CAPI
20
21 %package devel
22 Summary:        Development package for Tethering framework library
23 Group:          Development/Libraries
24 Requires:       %{name} = %{version}-%{release}
25 %description devel
26 Development package for Tethering framework library
27
28 %prep
29 %setup -q
30
31 %build
32 %ifarch %{arm}
33 %cmake . -DARCH=arm
34 %else
35 %if 0%{?simulator}
36 %cmake . -DARCH=emul
37 %else
38 %cmake . -DARCH=i586
39 %endif
40 %endif
41 make %{?jobs:-j%jobs}
42
43 %install
44 %make_install
45
46 %post -p /sbin/ldconfig
47
48 %postun -p /sbin/ldconfig
49
50 %files
51 %manifest capi-network-tethering.manifest
52 %defattr(-,root,root,-)
53 %{_libdir}/*.so.*
54 %ifarch %{arm}
55 /etc/config/connectivity/sysinfo-tethering.xml
56 %else
57 %if 0%{?simulator}
58 # Noop
59 %else
60 /etc/config/connectivity/sysinfo-tethering.xml
61 %endif
62 %endif
63
64 %files devel
65 %defattr(-,root,root,-)
66 %{_includedir}/network/*.h
67 %{_libdir}/pkgconfig/*.pc
68 %{_libdir}/*.so
69
70 %changelog
71 * Sat Feb 16 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.0.13-1
72 - Wrong linker flags are fixed
73 - Add API : tethering_wifi_set_ssid()
74
75 * Thu Feb 14 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.0.12-1
76 - APIs are exported
77 - LOG Format is changed
78 - fvisibility=hidden is applied and API's return value is checked
79
80 * Thu Jan 24 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.0.11-1
81 - Indications for Wi-Fi tethering setting change are added
82 - Dbus service / interface / object names are changed
83
84 * Tue Jan 15 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.0.10-1
85 - Wi-Fi tethering state is not checked when its settings are modified
86
87 * Fri Nov 02 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.9-1
88 - Manifest file is added for SMACK
89
90 * Mon Aug 20 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.8-1
91 - Deprecated APIs are removed
92
93 * Wed Aug 01 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.7-1
94 - Managed APIs are implemented for Wi-Fi tethering settings
95
96 * Sat Jul 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.6-1
97 - Fix tethering callback issue (JIRA S1-6197)
98
99 * Tue Jul 10 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.5
100 - Getting MAC address API is implemented
101 - TETHERING_TYPE_ALL case is implemented
102 - Test code is implemented
103
104 * Tue Jun 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.4
105 - All internal APIs are implemented
106
107 * Fri Jun 15 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.3
108 - Deprecated API from Glib2-2.32.3 is replaced with new one