1 Name: capi-network-tethering
2 Summary: Tethering Framework
7 Source0: %{name}-%{version}.tar.gz
8 BuildRequires: pkgconfig(dlog)
9 BuildRequires: pkgconfig(dbus-1)
10 BuildRequires: pkgconfig(capi-base-common)
11 BuildRequires: pkgconfig(glib-2.0)
12 BuildRequires: pkgconfig(gio-2.0)
13 BuildRequires: pkgconfig(vconf)
14 BuildRequires: pkgconfig(key-manager)
15 BuildRequires: pkgconfig(libssl)
16 BuildRequires: pkgconfig(capi-system-info)
18 Requires(post): /sbin/ldconfig
19 Requires(postun): /sbin/ldconfig
22 Tethering framework library for CAPI
25 Summary: Development package for Tethering framework library
26 Group: Development/Libraries
27 Requires: %{name} = %{version}-%{release}
29 Development package for Tethering framework library
36 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
37 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
38 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
40 %cmake -DCMAKE_BUILD_TYPE="Private" \
41 %if "%{?profile}" == "wearable"
44 %if "%{?profile}" == "mobile"
49 -DCMAKE_BUILD_TYPE="Private" -DARCH=arm \
52 -DCMAKE_BUILD_TYPE="Private" -DARCH=emul \
54 -DCMAKE_BUILD_TYPE="Private" -DARCH=i586 \
65 mkdir -p %{buildroot}/usr/share/license
66 cp LICENSE.APLv2.0 %{buildroot}/usr/share/license/capi-network-tethering
67 cp LICENSE.APLv2.0 %{buildroot}/usr/share/license/capi-network-tethering-devel
69 %post -p /sbin/ldconfig
71 %postun -p /sbin/ldconfig
74 %manifest capi-network-tethering.manifest
75 %defattr(-,root,root,-)
77 /usr/share/license/capi-network-tethering
78 %{_bindir}/tethering_test
80 /etc/config/connectivity/sysinfo-tethering.xml
85 /etc/config/connectivity/sysinfo-tethering.xml
90 %defattr(-,root,root,-)
91 %{_includedir}/network/*.h
92 %{_libdir}/pkgconfig/*.pc
94 /usr/share/license/capi-network-tethering-devel