Upload package
[platform/core/api/tethering.git] / packaging / capi-network-tethering.spec
1 Name:       capi-network-tethering
2 Summary:    Tethering Framework
3 Version:    0.0.12
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Requires(post):   /sbin/ldconfig
9 Requires(postun): /sbin/ldconfig
10
11 BuildRequires: pkgconfig(dlog)
12 BuildRequires: pkgconfig(dbus-glib-1)
13 BuildRequires: pkgconfig(capi-base-common)
14 BuildRequires: pkgconfig(glib-2.0)
15 BuildRequires: pkgconfig(vconf)
16 BuildRequires: cmake
17
18 %description
19 Tethering framework library for CAPI
20
21 %package devel
22 Summary:        Development package for Tethering framework library
23 Group:          Development/Libraries
24 Requires:       %{name} = %{version}-%{release}
25 %description devel
26 Development package for Tethering framework library
27
28 %prep
29 %setup -q
30
31 %build
32 %cmake .
33 make %{?jobs:-j%jobs}
34
35 %install
36 %make_install
37
38 %post -p /sbin/ldconfig
39
40 %postun -p /sbin/ldconfig
41
42 %files
43 %manifest capi-network-tethering.manifest
44 %defattr(-,root,root,-)
45 %{_libdir}/*.so.*
46
47 %files devel
48 %defattr(-,root,root,-)
49 %{_includedir}/network/*.h
50 %{_libdir}/pkgconfig/*.pc
51 %{_libdir}/*.so
52
53 %changelog
54 * Thu Feb 14 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.0.12-1
55 - APIs are exported
56 - LOG Format is changed
57 - fvisibility=hidden is applied and API's return value is checked
58
59 * Thu Jan 24 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.0.11-1
60 - Indications for Wi-Fi tethering setting change are added
61 - Dbus service / interface / object names are changed
62
63 * Tue Jan 15 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.0.10-1
64 - Wi-Fi tethering state is not checked when its settings are modified
65
66 * Fri Nov 02 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.9-1
67 - Manifest file is added for SMACK
68
69 * Mon Aug 20 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.8-1
70 - Deprecated APIs are removed
71
72 * Wed Aug 01 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.7-1
73 - Managed APIs are implemented for Wi-Fi tethering settings
74
75 * Sat Jul 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.6-1
76 - Fix tethering callback issue (JIRA S1-6197)
77
78 * Tue Jul 10 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.5
79 - Getting MAC address API is implemented
80 - TETHERING_TYPE_ALL case is implemented
81 - Test code is implemented
82
83 * Tue Jun 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.4
84 - All internal APIs are implemented
85
86 * Fri Jun 15 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.3
87 - Deprecated API from Glib2-2.32.3 is replaced with new one