Source code upload
[platform/core/api/tethering.git] / packaging / capi-network-tethering.spec
1 Name:       capi-network-tethering
2 Summary:    Tethering Framework
3 Version:    0.0.8
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    TO_BE/FILLED_IN
7 Source0:    %{name}-%{version}.tar.gz
8 Requires(post):   /sbin/ldconfig
9 Requires(postun): /sbin/ldconfig
10
11 BuildRequires: pkgconfig(dlog)
12 BuildRequires: pkgconfig(dbus-glib-1)
13 BuildRequires: pkgconfig(capi-base-common)
14 BuildRequires: pkgconfig(glib-2.0)
15 BuildRequires: pkgconfig(vconf)
16 BuildRequires: cmake
17
18 %description
19 Tethering framework library for CAPI
20
21 %package devel
22 Summary:        Development package for Tethering framework library
23 Group:          Development/Libraries
24 Requires:       %{name} = %{version}-%{release}
25 %description devel
26 Development package for Tethering framework library
27
28 %prep
29 %setup -q
30
31 %build
32 cmake . -DCMAKE_INSTALL_PREFIX=/usr
33
34 make %{?jobs:-j%jobs}
35
36 %install
37 rm -rf %{buildroot}
38 %make_install
39
40 %post -p /sbin/ldconfig
41
42 %postun -p /sbin/ldconfig
43
44 %files
45 %defattr(-,root,root,-)
46 %{_libdir}/*.so.*
47
48 %files devel
49 %defattr(-,root,root,-)
50 %{_includedir}/network/*.h
51 %{_libdir}/pkgconfig/*.pc
52 %{_libdir}/*.so
53
54 %changelog
55 * Mon Aug 20 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.8-1
56 - Deprecated APIs are removed
57
58 * Wed Aug 01 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.7-1
59 - Managed APIs are implemented for Wi-Fi tethering settings
60
61 * Sat Jul 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.6-1
62 - Fix tethering callback issue (JIRA S1-6197)
63
64 * Tue Jul 10 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.5
65 - Getting MAC address API is implemented
66 - TETHERING_TYPE_ALL case is implemented
67 - Test code is implemented
68
69 * Tue Jun 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.4
70 - All internal APIs are implemented
71
72 * Fri Jun 15 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.3
73 - Deprecated API from Glib2-2.32.3 is replaced with new one