SMACK manifest file is added
[platform/core/api/tethering.git] / packaging / capi-network-tethering.spec
1 Name:       capi-network-tethering
2 Summary:    Tethering Framework
3 Version:    0.0.9
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    TO_BE/FILLED_IN
7 Source0:    %{name}-%{version}.tar.gz
8 Requires(post):   /sbin/ldconfig
9 Requires(postun): /sbin/ldconfig
10
11 BuildRequires: pkgconfig(dlog)
12 BuildRequires: pkgconfig(dbus-glib-1)
13 BuildRequires: pkgconfig(capi-base-common)
14 BuildRequires: pkgconfig(glib-2.0)
15 BuildRequires: pkgconfig(vconf)
16 BuildRequires: cmake
17
18 %description
19 Tethering framework library for CAPI
20
21 %package devel
22 Summary:        Development package for Tethering framework library
23 Group:          Development/Libraries
24 Requires:       %{name} = %{version}-%{release}
25 %description devel
26 Development package for Tethering framework library
27
28 %prep
29 %setup -q
30
31 %build
32 cmake . -DCMAKE_INSTALL_PREFIX=/usr
33
34 make %{?jobs:-j%jobs}
35
36 %install
37 rm -rf %{buildroot}
38 %make_install
39
40 %post -p /sbin/ldconfig
41
42 %postun -p /sbin/ldconfig
43
44 %files
45 %manifest capi-network-tethering.manifest
46 %defattr(-,root,root,-)
47 %{_libdir}/*.so.*
48
49 %files devel
50 %defattr(-,root,root,-)
51 %{_includedir}/network/*.h
52 %{_libdir}/pkgconfig/*.pc
53 %{_libdir}/*.so
54
55 %changelog
56 * Fri Nov 02 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.9-1
57 - Manifest file is added for SMACK
58
59 * Mon Aug 20 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.8-1
60 - Deprecated APIs are removed
61
62 * Wed Aug 01 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.7-1
63 - Managed APIs are implemented for Wi-Fi tethering settings
64
65 * Sat Jul 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.6-1
66 - Fix tethering callback issue (JIRA S1-6197)
67
68 * Tue Jul 10 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.5
69 - Getting MAC address API is implemented
70 - TETHERING_TYPE_ALL case is implemented
71 - Test code is implemented
72
73 * Tue Jun 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.4
74 - All internal APIs are implemented
75
76 * Fri Jun 15 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.0.3
77 - Deprecated API from Glib2-2.32.3 is replaced with new one