Add new rpm package for test application #2
[platform/core/api/tethering.git] / packaging / capi-network-tethering.spec
1 Name:           capi-network-tethering
2 Summary:        Tethering Framework
3 Version:        1.0.56
4 Release:        1
5 Group:          System/Network
6 License:        Apache-2.0
7 Source0:        %{name}-%{version}.tar.gz
8 BuildRequires:  pkgconfig(dlog)
9 BuildRequires:  pkgconfig(dbus-1)
10 BuildRequires:  pkgconfig(capi-base-common)
11 BuildRequires:  pkgconfig(glib-2.0)
12 BuildRequires:  pkgconfig(gio-2.0)
13 BuildRequires:  pkgconfig(vconf)
14 BuildRequires:  pkgconfig(key-manager)
15 BuildRequires:  pkgconfig(libssl)
16 BuildRequires:  pkgconfig(capi-system-info)
17 BuildRequires:  pkgconfig(libtzplatform-config)
18 BuildRequires:  cmake
19 Requires(post):         /sbin/ldconfig
20 Requires(postun):       /sbin/ldconfig
21
22 %description
23 Tethering framework library for CAPI
24
25 %package devel
26 Summary:        Development package for Tethering framework library
27 Group:          Development/Libraries
28 Requires:       %{name} = %{version}-%{release}
29 %description devel
30 Development package for Tethering framework library
31
32 %package tool
33 Summary:        Test application for Tethering
34 %description tool
35 Test application for Tethering
36
37
38 %prep
39 %setup -q
40
41
42 %build
43 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
44 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
45 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
46
47 %cmake .
48
49 make %{?_smp_mflags}
50
51
52 %install
53 %make_install
54
55 %post -p /sbin/ldconfig
56
57 %postun -p /sbin/ldconfig
58
59 %files
60 %manifest capi-network-tethering.manifest
61 %defattr(-,root,root,-)
62 %{_libdir}/*.so.*
63 %license LICENSE
64
65 %files devel
66 %defattr(-,root,root,-)
67 %{_includedir}/network/*.h
68 %{_libdir}/pkgconfig/*.pc
69 %{_libdir}/*.so
70 %license LICENSE
71
72 %files tool
73 %{_bindir}/tethering_test