6a009125b45fa4c7db3cbb98aa115d3fb584ab6d
[platform/core/api/tethering.git] / packaging / capi-network-tethering.spec
1 Name:       capi-network-tethering
2 Summary:    Tethering Framework
3 Version:    0.0.16
4 Release:    1
5 Group:      Connectivity/API
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source1001:     capi-network-tethering.manifest
9
10 BuildRequires: pkgconfig(dlog)
11 BuildRequires: pkgconfig(dbus-glib-1)
12 BuildRequires: pkgconfig(capi-base-common)
13 BuildRequires: pkgconfig(glib-2.0)
14 BuildRequires: pkgconfig(vconf)
15 BuildRequires: cmake
16
17 %description
18 Tethering framework library for CAPI
19
20 %package devel
21 Summary:        Development package for Tethering framework library
22 Group:          Connectivity/Development
23 Requires:       %{name} = %{version}-%{release}
24 %description devel
25 Development package for Tethering framework library
26
27 %prep
28 %setup -q
29 cp %{SOURCE1001} .
30
31 %build
32 %ifarch %{arm}
33 %cmake . -DARCH=arm
34 %else
35 %if 0%{?simulator}
36 %cmake . -DARCH=emul
37 %else
38 %cmake . -DARCH=i586
39 %endif
40 %endif
41 make %{?jobs:-j%jobs}
42
43 %install
44 %make_install
45 mkdir -p %{buildroot}/usr/share/license
46 cp LICENSE.APLv2.0 %{buildroot}/usr/share/license/%{name}
47
48 %post -p /sbin/ldconfig
49
50 %postun -p /sbin/ldconfig
51
52 %files
53 %manifest %{name}.manifest
54 %defattr(-,root,root,-)
55 %{_libdir}/*.so.*
56 /usr/share/license/%{name}
57 %ifarch %{arm}
58 /etc/config/connectivity/sysinfo-tethering.xml
59 %else
60 %if 0%{?simulator}
61 # Noop
62 %else
63 /etc/config/connectivity/sysinfo-tethering.xml
64 %endif
65 %endif
66
67 %files devel
68 %manifest %{name}.manifest
69 %defattr(-,root,root,-)
70 %{_includedir}/network/*.h
71 %{_libdir}/pkgconfig/*.pc
72 %{_libdir}/*.so
73