resetting manifest requested domain to floor
[platform/core/api/tethering.git] / packaging / capi-network-tethering.spec
1 Name:       capi-network-tethering
2 Summary:    Tethering Framework
3 Version:    0.0.15
4 Release:    1
5 Group:      Connectivity/API
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source1001:     capi-network-tethering.manifest
9
10 BuildRequires: pkgconfig(dlog)
11 BuildRequires: pkgconfig(dbus-glib-1)
12 BuildRequires: pkgconfig(capi-base-common)
13 BuildRequires: pkgconfig(glib-2.0)
14 BuildRequires: pkgconfig(vconf)
15 BuildRequires: cmake
16
17 %description
18 Tethering framework library for CAPI
19
20 %package devel
21 Summary:        Development package for Tethering framework library
22 Group:          Connectivity/Development
23 Requires:       %{name} = %{version}-%{release}
24 %description devel
25 Development package for Tethering framework library
26
27 %prep
28 %setup -q
29 cp %{SOURCE1001} .
30
31 %build
32 %ifarch %{arm}
33 %cmake . -DARCH=arm
34 %else
35 %if 0%{?simulator}
36 %cmake . -DARCH=emul
37 %else
38 %cmake . -DARCH=i586
39 %endif
40 %endif
41 make %{?jobs:-j%jobs}
42
43 %install
44 %make_install
45
46 %post -p /sbin/ldconfig
47
48 %postun -p /sbin/ldconfig
49
50 %files
51 %manifest %{name}.manifest
52 %defattr(-,root,root,-)
53 %{_libdir}/*.so.*
54 %ifarch %{arm}
55 /etc/config/connectivity/sysinfo-tethering.xml
56 %else
57 %if 0%{?simulator}
58 # Noop
59 %else
60 /etc/config/connectivity/sysinfo-tethering.xml
61 %endif
62 %endif
63
64 %files devel
65 %manifest %{name}.manifest
66 %defattr(-,root,root,-)
67 %{_includedir}/network/*.h
68 %{_libdir}/pkgconfig/*.pc
69 %{_libdir}/*.so
70