3fb20047d30722d861edbf21f3b5b67bb5161911
[platform/core/api/tethering.git] / packaging / capi-network-tethering.spec
1 Name:       capi-network-tethering
2 Summary:    Tethering Framework
3 Version:    0.0.15
4 Release:    1
5 Group:      Connectivity/API
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8
9 BuildRequires: pkgconfig(dlog)
10 BuildRequires: pkgconfig(dbus-glib-1)
11 BuildRequires: pkgconfig(capi-base-common)
12 BuildRequires: pkgconfig(glib-2.0)
13 BuildRequires: pkgconfig(vconf)
14 BuildRequires: cmake
15
16 %description
17 Tethering framework library for CAPI
18
19 %package devel
20 Summary:        Development package for Tethering framework library
21 Group:          Connectivity/Development
22 Requires:       %{name} = %{version}-%{release}
23 %description devel
24 Development package for Tethering framework library
25
26 %prep
27 %setup -q
28
29 %build
30 %ifarch %{arm}
31 %cmake . -DARCH=arm
32 %else
33 %if 0%{?simulator}
34 %cmake . -DARCH=emul
35 %else
36 %cmake . -DARCH=i586
37 %endif
38 %endif
39 make %{?jobs:-j%jobs}
40
41 %install
42 %make_install
43
44 %post -p /sbin/ldconfig
45
46 %postun -p /sbin/ldconfig
47
48 %files
49 %manifest capi-network-tethering.manifest
50 %defattr(-,root,root,-)
51 %{_libdir}/*.so.*
52 %ifarch %{arm}
53 /etc/config/connectivity/sysinfo-tethering.xml
54 %else
55 %if 0%{?simulator}
56 # Noop
57 %else
58 /etc/config/connectivity/sysinfo-tethering.xml
59 %endif
60 %endif
61
62 %files devel
63 %defattr(-,root,root,-)
64 %{_includedir}/network/*.h
65 %{_libdir}/pkgconfig/*.pc
66 %{_libdir}/*.so
67