Fixed a build error due to dlog update
[platform/core/api/smartcard.git] / packaging / capi-network-smartcard.spec
1 Name:       capi-network-smartcard
2 Summary:    A Smartcard library in Native API
3 Version:    0.0.14
4 Release:    0
5 Group:      Network & Connectivity/Smartcard
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(dlog)
10 BuildRequires:  pkgconfig(glib-2.0)
11 BuildRequires:  pkgconfig(gobject-2.0)
12 BuildRequires:  pkgconfig(smartcard-service-common)
13 BuildRequires:  pkgconfig(capi-base-common)
14 BuildRequires:  pkgconfig(capi-system-info)
15
16 Requires(post): /sbin/ldconfig
17 Requires(postun): /sbin/ldconfig
18
19 %description
20
21 %package devel
22 Summary:  A Smartcard library in Native API (Development)
23 Group:    Network & Connectivity/Development
24 Requires: %{name} = %{version}-%{release}
25
26 %description devel
27
28 %prep
29 %setup -q
30
31 %build
32 %if 0%{?gcov:1}
33 export LDFLAGS+=" -lgcov"
34 %endif
35
36 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
37
38 cmake . -DCMAKE_INSTALL_PREFIX=/usr -DFULLVER=%{version} \
39         -DMAJORVER=${MAJORVER} -DCMAKE_LIB_DIR=%{_libdir} -DBUILD_GCOV=%{?gcov:1}%{!?gcov:0} \
40 %ifarch %{arm}
41         -DTIZEN_SMARTCARD_SUPPORT=1
42 %endif
43
44
45 make %{?jobs:-j%jobs}
46
47 %install
48 rm -rf %{buildroot}
49
50 %make_install
51
52 %post -p /sbin/ldconfig
53
54 %postun -p /sbin/ldconfig
55
56
57 %files
58 %manifest capi-network-smartcard.manifest
59 %license LICENSE.APLv2
60 %{_libdir}/libcapi-network-smartcard.so*
61
62 %files devel
63 %{_includedir}/*.h
64 %{_libdir}/pkgconfig/*.pc
65 %{_libdir}/libcapi-network-smartcard.so
66 %{_bindir}/smartcard_unit_test