Remove the code to unset event (BT_EVENT_RFCOMM_CONNECTION_REQUESTED)
[framework/api/bluetooth.git] / packaging / capi-network-bluetooth.spec
1 #sbs-git:slp/api/bluetooth capi-network-bluetooth 0.1.0 686c444083e4197845c768e5dd034022b1dfa250
2 Name:       capi-network-bluetooth
3 Summary:    Network Bluetooth Framework
4 Version: 0.1.13
5 Release:    1
6 Group:      TO_BE/FILLED_IN
7 License:    TO BE FILLED IN
8 Source0:    %{name}-%{version}.tar.gz
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11
12 BuildRequires:  pkgconfig(dbus-glib-1)
13 BuildRequires:  pkgconfig(dlog)
14 BuildRequires:  pkgconfig(glib-2.0)
15 BuildRequires:  pkgconfig(vconf)
16 BuildRequires:  pkgconfig(bluetooth-api)
17 BuildRequires:  pkgconfig(capi-base-common)
18
19 BuildRequires:  cmake
20
21
22 %description
23 Network Bluetooth Framework
24
25 %package devel
26 Summary:    Network Bluetooth Framework (DEV)
27 Group:      TO_BE/FILLED
28 Requires:   %{name} = %{version}-%{release}
29
30 %description devel
31 Network Bluetooth Framework (DEV).
32
33 %prep
34 %setup -q
35
36 %build
37 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
38 cmake . -DCMAKE_INSTALL_PREFIX=/usr -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
39
40 make %{?jobs:-j%jobs}
41
42 %install
43 rm -rf %{buildroot}
44 %make_install
45
46
47 %post -p /sbin/ldconfig
48
49 %postun -p /sbin/ldconfig
50
51 %files
52 %{_libdir}/libcapi-network-bluetooth.so.*
53
54 %files devel
55 %{_includedir}/network/bluetooth.h
56 %{_libdir}/pkgconfig/capi-network-bluetooth.pc
57 %{_libdir}/libcapi-network-bluetooth.so
58