update for beta universally
[framework/api/wav-player.git] / packaging / capi-media-wav-player.spec
1 Name:       capi-media-wav-player
2 Summary:    A wav player library in Tizen Native API
3 Version:    0.1.0
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(mm-sound)
10 BuildRequires:  pkgconfig(dlog)
11 BuildRequires:  pkgconfig(capi-base-common)
12 BuildRequires:  pkgconfig(capi-media-sound-manager)
13 Requires(post): /sbin/ldconfig  
14 Requires(postun): /sbin/ldconfig
15
16 %description
17
18
19 %package devel
20 Summary:  A wav player library in Tizen Native API (Development)
21 Group:    TO_BE/FILLED_IN
22 Requires: %{name} = %{version}-%{release}
23
24 %description devel
25
26
27
28 %prep
29 %setup -q
30
31
32 %build
33 FULLVER=%{version}
34 MAJORVER=`echo ${FULLVER} | cut -d '.' -f 1`
35 cmake . -DFULLVER=${FULLVER} -DMAJORVER=${MAJORVER}
36
37 make %{?jobs:-j%jobs}
38
39 %install
40 rm -rf %{buildroot}
41 %make_install
42
43 %post -p /sbin/ldconfig
44
45 %postun -p /sbin/ldconfig
46
47
48 %files
49 %{_libdir}/libcapi-media-wav-player.so*
50
51 %files devel
52 %{_includedir}/media/*.h
53 %{_libdir}/pkgconfig/*.pc