Change log tag prefix to TIZEN_N
[platform/core/api/tone-player.git] / packaging / capi-media-tone-player.spec
1 Name:       capi-media-tone-player
2 Summary:    A tone player library in Tizen C API
3 Version:    0.1.9
4 Release:    0
5 Group:      Multimedia/API
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source1001:     capi-media-tone-player.manifest
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(mm-sound)
11 BuildRequires:  pkgconfig(dlog)
12 BuildRequires:  pkgconfig(capi-base-common)
13 BuildRequires:  pkgconfig(capi-media-sound-manager)
14
15 %description
16 A tone player library in Tizen C API.
17
18
19 %package devel
20 Summary:  A tone player library in Tizen C API (Development)
21 Group:    Development/Multimedia
22 Requires: %{name} = %{version}-%{release}
23
24 %description devel
25 %devel_desc
26
27
28
29 %prep
30 %setup -q
31 cp %{SOURCE1001} .
32
33
34 %build
35 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
36 %cmake . -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
37
38
39 make %{?jobs:-j%jobs}
40
41 %install
42 %make_install
43
44 %post -p /sbin/ldconfig
45
46 %postun -p /sbin/ldconfig
47
48
49 %files
50 %manifest %{name}.manifest
51 %license LICENSE
52 %{_libdir}/libcapi-media-tone-player.so.*
53
54 %files devel
55 %manifest %{name}.manifest
56 %{_includedir}/media/*.h
57 %{_libdir}/pkgconfig/*.pc
58 %{_libdir}/libcapi-media-tone-player.so