Adds testsuite for looback mode
[platform/core/api/mediastreamrecorder.git] / packaging / capi-media-streamrecorder.spec
1 Name:       capi-media-streamrecorder
2 Summary:    A Streamrecorder library in Tizen Native API
3 Version:    0.0.27
4 Release:    0
5 Group:      Multimedia/Other
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(dlog)
10 Buildrequires:  pkgconfig(mm-streamrecorder)
11 BuildRequires:  pkgconfig(capi-base-common)
12 BuildRequires:  pkgconfig(capi-media-tool)
13 BuildRequires:  pkgconfig(libtbm)
14 Requires(post): /sbin/ldconfig
15 Requires(postun): /sbin/ldconfig
16
17 %description
18 A StreamRecorder library in Tizen Native API to record live buffer sent by the application
19
20
21 %package devel
22 Summary:  A StreamRecorder library in Tizen Native API (Development)
23 Requires: %{name} = %{version}-%{release}
24
25
26 %description devel
27 A MediaStreamRecorder library in Tizen Native API Development Package to record live buffer
28
29 %if 0%{?gcov:1}
30 %package gcov
31 Summary: Line Coverage of Stream Recorder library in Tizen C API
32 Group: Development/Multimedia
33
34 %description gcov
35 Collection of files related to Line Coverage. It is teseted as gcov for a stream recorder library in Tizen native API
36 %endif
37
38 %prep
39 %setup -q
40
41
42 %build
43 %if 0%{?gcov:1}
44 export CFLAGS+=" -fprofile-arcs -ftest-coverage"
45 export CXXFLAGS+=" -fprofile-arcs -ftest-coverage"
46 export FFLAGS+=" -fprofile-arcs -ftest-coverage"
47 export LDFLAGS+=" -lgcov"
48 %endif
49
50 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
51 %cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
52
53
54 make %{?jobs:-j%jobs}
55
56 %if 0%{?gcov:1}
57 mkdir -p gcov-obj
58 find . -name '*.gcno' -exec cp '{}' gcov-obj ';'
59 %endif
60
61 %install
62 rm -rf %{buildroot}
63 %make_install
64
65 %if 0%{?gcov:1}
66 mkdir -p %{buildroot}%{_datadir}/gcov/obj
67 install -m 0644 gcov-obj/* %{buildroot}%{_datadir}/gcov/obj
68 %endif
69
70 %post -p /sbin/ldconfig
71
72
73 %postun -p /sbin/ldconfig
74
75 %files
76 %manifest capi-media-streamrecorder.manifest
77 %license LICENSE.APLv2
78 %{_libdir}/libcapi-media-streamrecorder.so.*
79 %{_bindir}/*
80
81 %files devel
82 %{_includedir}/media/streamrecorder.h
83 %{_libdir}/pkgconfig/*.pc
84 %{_libdir}/libcapi-media-streamrecorder.so
85
86 %if 0%{?gcov:1}
87 %files gcov
88 %{_datadir}/gcov/obj/*
89 %endif