Remove placeholders and cleanup spec
[platform/core/api/location-manager.git] / packaging / capi-location-manager.spec
1 Name:       capi-location-manager
2 Summary:    A Location Manager library in Tizen Native API
3 Version: 0.1.11
4 Release:    1
5 Group:      Location/API
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(dlog)
10 BuildRequires:  pkgconfig(location)
11 BuildRequires:  pkgconfig(capi-base-common)
12
13 %description
14 A Location Manager library in Tizen Native API.
15
16
17 %package devel
18 Summary:  A Location Manager library in Tizen Native API (Development)
19 Group:    Location/Development
20 Requires: %{name} = %{version}-%{release}
21
22 %description devel
23 %devel_desc
24
25
26
27 %prep
28 %setup -q
29
30
31 %build
32 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
33 %cmake . -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
34
35 make %{?jobs:-j%jobs}
36
37 %install
38 %make_install
39
40 %post -p /sbin/ldconfig
41
42 %postun -p /sbin/ldconfig
43
44
45 %files
46 %license LICENSE
47 %manifest capi-location-manager.manifest
48 %{_libdir}/libcapi-location-manager.so.*
49
50 %files devel
51 %{_includedir}/location/*.h
52 %{_libdir}/pkgconfig/*.pc
53 %{_libdir}/libcapi-location-manager.so
54
55