update for beta universally
[framework/api/location-manager.git] / packaging / capi-location-manager.spec
1 Name:       capi-location-manager
2 Summary:    A Location Manager library in Tizen Native API
3 Version:    0.1.0
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(dlog)
10 BuildRequires:  pkgconfig(location)
11 BuildRequires:  pkgconfig(capi-base-common)
12 Requires(post): /sbin/ldconfig  
13 Requires(postun): /sbin/ldconfig
14
15 %description
16
17
18 %package devel
19 Summary:  A Location Manager library in Tizen Native API (Development)
20 Group:    TO_BE/FILLED_IN
21 Requires: %{name} = %{version}-%{release}
22
23 %description devel
24
25
26
27 %prep
28 %setup -q
29
30
31 %build
32 FULLVER=%{version}
33 MAJORVER=`echo ${FULLVER} | cut -d '.' -f 1`
34 cmake . -DCMAKE_INSTALL_PREFIX=/usr -DFULLVER=${FULLVER} -DMAJORVER=${MAJORVER}
35
36
37 make %{?jobs:-j%jobs}
38
39 %install
40 rm -rf %{buildroot}
41 %make_install
42
43 %post -p /sbin/ldconfig
44
45 %postun -p /sbin/ldconfig
46
47
48 %files
49 %{_libdir}/libcapi-location-manager.so*
50
51 %files devel
52 %{_includedir}/location/*.h
53 %{_libdir}/pkgconfig/*.pc
54
55