Clean spec file for yocto complaince.
[platform/core/api/location-manager.git] / packaging / capi-location-manager.spec
1 Name:       capi-location-manager
2 Summary:    A Location Manager library in Tizen Native API
3 Version:    0.1.11
4 Release:    0
5 Group:      Location/API
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source1001:     capi-location-manager.manifest
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(dlog)
11 BuildRequires:  pkgconfig(location)
12 BuildRequires:  pkgconfig(capi-base-common)
13
14 %description
15 A Location Manager library in Tizen Native API package.
16
17 %package devel
18 Summary:  A Location Manager library in Tizen Native API (Development)
19 Group:    Location/Development
20 Requires: %{name} = %{version}-%{release}
21
22 %description devel
23 A Location Manager library in Tizen Native API (Development) package.
24 %devel_desc
25
26 %prep
27 %setup -q
28 cp %{SOURCE1001} .
29
30 %build
31 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
32 %cmake . -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
33 %__make %{?jobs:-j%jobs}
34
35 %install
36 %make_install
37
38 %post -p /sbin/ldconfig
39
40 %postun -p /sbin/ldconfig
41
42 %files
43 %manifest %{name}.manifest
44 %license LICENSE
45 %{_libdir}/libcapi-location-manager.so.*
46
47 %files devel
48 %manifest %{name}.manifest
49 %{_includedir}/location/*.h
50 %{_libdir}/pkgconfig/*.pc
51 %{_libdir}/libcapi-location-manager.so