f8ee07d5da955518723a4fc72be6e4db02e97f16
[platform/core/api/geocoder.git] / packaging / capi-location-geocoder.spec
1 Name:       capi-location-geocoder
2 Summary:    A Geocoder library in Tizen Native API
3 Version:    0.1.2
4 Release:    1
5 Group:      System/Libraries
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(dlog)
10 BuildRequires:  pkgconfig(location)
11 BuildRequires:  pkgconfig(capi-base-common)
12
13 %description
14 A Geocoder library in Tizen Native API.
15
16
17 %package devel
18 Summary:  A Geocoder library in Tizen Native API (Development)
19 Group:    Development/Libraries
20 Requires: %{name} = %{version}
21
22 %description devel
23 A Geocoder library in Tizen Native API (Development).
24
25
26 %prep
27 %setup -q
28
29
30 %build
31 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
32 %cmake . -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
33 make %{?jobs:-j%jobs}
34
35 %install
36 %make_install
37
38 %post -p /sbin/ldconfig
39
40 %postun -p /sbin/ldconfig
41
42
43 %files
44 %license LICENSE
45 %{_libdir}/libcapi-location-geocoder.so*
46 %manifest capi-location-geocoder.manifest
47
48 %files devel
49 %{_includedir}/location/geocoder.h
50 %{_libdir}/pkgconfig/*.pc