Add default Smack manifest for capi-location-geocoder.spec
[framework/api/geocoder.git] / packaging / capi-location-geocoder.spec
1 Name:       capi-location-geocoder
2 Summary:    A Geocoder library in Tizen Native API
3 Version: 0.1.0
4 Release:    14
5 Group:      TO_BE/FILLED_IN
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source1001: packaging/capi-location-geocoder.manifest 
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(dlog)
11 BuildRequires:  pkgconfig(location)
12 BuildRequires:  pkgconfig(capi-base-common)
13 Requires(post): /sbin/ldconfig  
14 Requires(postun): /sbin/ldconfig
15
16 %description
17
18
19 %package devel
20 Summary:  A Geocoder library in Tizen Native API (Development)
21 Group:    TO_BE/FILLED_IN
22 Requires: %{name} = %{version}-%{release}
23
24 %description devel
25
26
27
28 %prep
29 %setup -q
30
31
32 %build
33 cp %{SOURCE1001} .
34 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
35 cmake . -DCMAKE_INSTALL_PREFIX=/usr -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
36
37
38 make %{?jobs:-j%jobs}
39
40 %install
41 rm -rf %{buildroot}
42 %make_install
43
44 %post -p /sbin/ldconfig
45
46 %postun -p /sbin/ldconfig
47
48
49 %files
50 %manifest capi-location-geocoder.manifest
51 %{_libdir}/libcapi-location-geocoder.so*
52
53 %files devel
54 %manifest capi-location-geocoder.manifest
55 %{_includedir}/location/geocoder.h
56 %{_libdir}/pkgconfig/*.pc