resetting manifest requested domain to floor
[platform/core/api/geocoder.git] / packaging / capi-location-geocoder.spec
1 Name:       capi-location-geocoder
2 Summary:    A Geocoder library in Tizen Native API
3 Version:    0.1.2
4 Release:    1
5 Group:      System/Libraries
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source1001:     capi-location-geocoder.manifest
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(dlog)
11 BuildRequires:  pkgconfig(location)
12 BuildRequires:  pkgconfig(capi-base-common)
13
14 %description
15 A Geocoder library in Tizen Native API.
16
17
18 %package devel
19 Summary:  A Geocoder library in Tizen Native API (Development)
20 Group:    Development/Libraries
21 Requires: %{name} = %{version}
22
23 %description devel
24 A Geocoder library in Tizen Native API (Development).
25
26
27 %prep
28 %setup -q
29 cp %{SOURCE1001} .
30
31
32 %build
33 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
34 %cmake . -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
35 make %{?jobs:-j%jobs}
36
37 %install
38 %make_install
39
40 %post -p /sbin/ldconfig
41
42 %postun -p /sbin/ldconfig
43
44
45 %files
46 %manifest %{name}.manifest
47 %license LICENSE
48 %{_libdir}/libcapi-location-geocoder.so*
49 %manifest capi-location-geocoder.manifest
50
51 %files devel
52 %manifest %{name}.manifest
53 %{_includedir}/location/geocoder.h
54 %{_libdir}/pkgconfig/*.pc