Tizen 2.0 Release
[framework/api/geocoder.git] / packaging / capi-location-geocoder.spec
1 Name:       capi-location-geocoder
2 Summary:    A Geocoder library in Tizen Native API
3 Version:    0.1.2
4 Release:    1
5 Group:      System/Libraries
6 License:    Apache License, Version 2.0
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(dlog)
10 BuildRequires:  pkgconfig(location)
11 BuildRequires:  pkgconfig(capi-base-common)
12 Requires(post): /sbin/ldconfig  
13 Requires(postun): /sbin/ldconfig
14
15 %description
16
17
18 %package devel
19 Summary:  A Geocoder library in Tizen Native API (Development)
20 Group:    TO_BE/FILLED_IN
21 Requires: %{name} = %{version}-%{release}
22
23 %description devel
24
25
26
27 %prep
28 %setup -q
29
30
31 %build
32 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
33 cmake . -DCMAKE_INSTALL_PREFIX=/usr -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
34
35
36 make %{?jobs:-j%jobs}
37
38 %install
39 rm -rf %{buildroot}
40 %make_install
41
42 %post -p /sbin/ldconfig
43
44 %postun -p /sbin/ldconfig
45
46
47 %files
48 %manifest capi-location-geocoder.manifest
49 %{_libdir}/libcapi-location-geocoder.so*
50
51 %files devel
52 %{_includedir}/location/geocoder.h
53 %{_libdir}/pkgconfig/*.pc