Merge "[Base-utils] common header file updated" into tizen
[platform/core/api/base-utils.git] / packaging / capi-base-utils.spec
1 Name:       capi-base-utils
2 Summary:    Base Utils
3 Version:    1.2.3
4 Release:    1
5 Group:      Base
6 License:    Apache-2.0 and ICU
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(icu-i18n)
10 BuildRequires:  pkgconfig(capi-base-common)
11 BuildRequires:  pkgconfig(dlog)
12
13 Requires(post): /sbin/ldconfig
14 Requires(postun): /sbin/ldconfig
15         
16 %description
17 The base utils library for internationalization and localization
18
19 %package devel
20 License:    Apache-2.0 and ICU
21 Summary:    The Base Utils Library (Development)
22 Group:      Base
23 Requires:   %{name} = %{version}-%{release}
24
25 %description devel
26 The base utils library for internationalization and localization (Development)
27
28 %prep
29 %setup -q
30
31 %build
32 #export CFLAGS="$CFLAGS -Wall -Werror -Wno-unused-function"
33 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIB_INSTALL_DIR:PATH=%{_libdir} -DINCLUDE_INSTALL_DIR:PATH=%{_includedir} \
34     -DPKG_NAME=%{name} -DPKG_VERSION=%{version} \
35 %if "%{profile}" == "wearable"
36     -DTIZEN_WEARABLE=YES \
37 %endif
38 %if "%{profile}" == "mobile"
39     -DTIZEN_MOBILE=YES \
40 %endif
41 %if "%{profile}" == "common"
42     -DTIZEN_MOBILE=YES \
43 %endif
44 %if "%{profile}" == "common_iot"
45     -DTIZEN_MOBILE=YES \
46 %endif
47
48
49 make %{?jobs:-j%jobs}
50
51 %install
52 rm -rf %{buildroot}
53 %make_install
54 mkdir -p %{buildroot}/usr/share/license
55 cp LICENSE %{buildroot}/usr/share/license/%{name}
56 cat LICENSE.ICU >> %{buildroot}/usr/share/license/%{name}
57
58 %post -p /sbin/ldconfig
59
60 %postun -p /sbin/ldconfig
61
62 %files
63 %manifest capi-base-utils.manifest
64 %{_libdir}/libbase-utils-i18n.so*
65 /usr/share/license/%{name}
66
67 %files devel
68 %defattr(-,root,root,-)
69 %{_includedir}/base/utils_i18n*.h
70 %{_libdir}/pkgconfig/*.pc