Fix wrong module error value
[platform/core/api/common.git] / packaging / capi-base-common.spec
1 Name:       capi-base-common
2 Summary:    Common header files of Tizen Native API
3 Version:    0.4.40
4 Release:    1
5 Group:      Base
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8
9 BuildRequires: cmake
10 Requires(post):   /sbin/ldconfig
11 Requires(postun): /sbin/ldconfig
12
13 %description
14 Common header files of Tizen Native API
15
16 %package devel
17 License:  Apache-2.0
18 Summary:  Common header files of Tizen Native API (Development)
19 Group:    Base
20 Requires: %{name} = %{version}-%{release}
21
22 %description devel
23 Common header files of Tizen Native API
24
25 %prep
26 %setup -q
27
28 %build
29
30 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
31
32 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIB_INSTALL_DIR:PATH=%{_libdir} -DINCLUDE_INSTALL_DIR:PATH=%{_includedir} \
33 -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
34
35 make %{?jobs:-j%jobs}
36
37 %install
38 rm -rf %{buildroot}
39 %make_install
40
41 %post -p /sbin/ldconfig
42
43 %postun -p /sbin/ldconfig
44
45 %files
46 %manifest %{name}.manifest
47 %{_libdir}/libcapi-base-common.so.*
48 %license LICENSE
49
50 %files devel
51 %{_includedir}/*.h
52 %{_libdir}/pkgconfig/capi-base-common.pc
53 %{_libdir}/libcapi-base-common.so