fix missed spelling
[platform/core/api/package-manager.git] / packaging / capi-appfw-package-manager.spec
1 Name:       capi-appfw-package-manager
2 Summary:    Package Manager API
3 Version: 0.0.27
4 Release:    1
5 Group:      API
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(dlog)
10 BuildRequires:  pkgconfig(pkgmgr)
11 BuildRequires:  pkgconfig(pkgmgr-info)
12 BuildRequires:  pkgconfig(ail)
13 BuildRequires:  pkgconfig(vconf)
14 BuildRequires:  pkgconfig(aul)
15 BuildRequires:  pkgconfig(capi-base-common)
16
17 %description
18 The Package Manager API provides functions to install, uninstall the package,
19 and also privides event listening function.
20
21 %package devel
22 Summary:  Package Manager API (Development)
23 Group:    API
24 Requires: %{name} = %{version}-%{release}
25
26 %description devel
27 The Package Manager API provides functions to install, uninstall the package,
28 and also privides event listening function. (DEV)
29
30
31 %prep
32 %setup -q
33
34
35 %build
36 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
37 %cmake . -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
38
39 make %{?jobs:-j%jobs}
40
41 %install
42 rm -rf %{buildroot}
43 %make_install
44
45 %post -p /sbin/ldconfig
46
47 %postun -p /sbin/ldconfig
48
49
50 %files
51 %manifest capi-appfw-package-manager.manifest
52 %{_libdir}/libcapi-appfw-package-manager.so.*
53 %{_bindir}/pkgmgr_tool
54
55 %files devel
56 %{_includedir}/appfw/package_manager.h
57 %{_includedir}/appfw/package_info.h
58 %{_libdir}/libcapi-appfw-package-manager.so
59 %{_libdir}/pkgconfig/*.pc
60
61