Fix rpmlint error for Group name
[platform/core/api/package-manager.git] / packaging / capi-appfw-package-manager.spec
1 Name:       capi-appfw-package-manager
2 Summary:    Package Manager API
3 Version: 0.0.28
4 Release:    1
5 Group:      System/API
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source1001:     capi-appfw-package-manager.manifest
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(dlog)
11 BuildRequires:  pkgconfig(pkgmgr)
12 BuildRequires:  pkgconfig(pkgmgr-info)
13 BuildRequires:  pkgconfig(ail)
14 BuildRequires:  pkgconfig(vconf)
15 BuildRequires:  pkgconfig(aul)
16 BuildRequires:  pkgconfig(capi-base-common)
17
18 %description
19 The Package Manager API provides functions to install, uninstall the package,
20 and also privides event listening function.
21
22 %package devel
23 Summary:  Package Manager API (Development)
24 Group:    System/API
25 Requires: %{name} = %{version}-%{release}
26
27 %description devel
28 The Package Manager API provides functions to install, uninstall the package,
29 and also privides event listening function. (DEV)
30
31
32 %prep
33 %setup -q
34 cp %{SOURCE1001} .
35
36
37 %build
38 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
39 %cmake . -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
40
41 make %{?jobs:-j%jobs}
42
43 %install
44 rm -rf %{buildroot}
45 %make_install
46
47 %post -p /sbin/ldconfig
48
49 %postun -p /sbin/ldconfig
50
51
52 %files
53 %manifest %{name}.manifest
54 %{_libdir}/libcapi-appfw-package-manager.so.*
55 %{_bindir}/pkgmgr_tool
56
57 %files devel
58 %manifest %{name}.manifest
59 %{_includedir}/appfw/package_manager.h
60 %{_includedir}/appfw/package_info.h
61 %{_libdir}/libcapi-appfw-package-manager.so
62 %{_libdir}/pkgconfig/*.pc
63
64