Seperate test tool into test package
[platform/core/api/package-manager.git] / packaging / capi-appfw-package-manager.spec
1 Name:       capi-appfw-package-manager
2 Summary:    Package Manager API
3 Version: 0.0.30
4 Release:    1
5 Group:      System/API
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source1001:     capi-appfw-package-manager.manifest
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(dlog)
11 BuildRequires:  pkgconfig(pkgmgr)
12 BuildRequires:  pkgconfig(pkgmgr-installer)
13 BuildRequires:  pkgconfig(pkgmgr-info)
14 BuildRequires:  pkgconfig(vconf)
15 BuildRequires:  pkgconfig(aul)
16 BuildRequires:  pkgconfig(capi-base-common)
17 BuildRequires:  pkgconfig(libtzplatform-config)
18 BuildRequires:  pkgconfig(glib-2.0)
19 BuildRequires:  pkgconfig(cynara-client)
20
21 %description
22 The Package Manager API provides functions to install, uninstall the package,
23 and also privides event listening function.
24
25 %package devel
26 Summary:  Package Manager API (Development)
27 Group:    System/API
28 Requires: %{name} = %{version}-%{release}
29
30 %description devel
31 The Package Manager API provides functions to install, uninstall the package,
32 and also privides event listening function. (DEV)
33
34 %package test
35 Summary:  Package Manager API (Test Tool)
36 Group:    System/API
37 Requires: %{name} = %{version}-%{release}
38
39 %description test
40 This package includes test tool for package manager apis.
41
42 %prep
43 %setup -q
44 cp %{SOURCE1001} .
45
46
47 %build
48 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
49 %cmake . -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
50
51 make %{?jobs:-j%jobs}
52
53 %install
54 rm -rf %{buildroot}
55 %make_install
56
57 %post -p /sbin/ldconfig
58
59 %postun -p /sbin/ldconfig
60
61
62 %files
63 %manifest %{name}.manifest
64 %{_libdir}/libcapi-appfw-package-manager.so.*
65
66 %files devel
67 %manifest %{name}.manifest
68 %{_includedir}/appfw/package_manager.h
69 %{_includedir}/appfw/package_info.h
70 %{_libdir}/libcapi-appfw-package-manager.so
71 %{_libdir}/pkgconfig/*.pc
72
73 %files test
74 %manifest %{name}.manifest
75 %{_bindir}/pkgmgr_tool