Tizen 2.1 base
[platform/core/api/package-manager.git] / packaging / capi-appfw-package-manager.spec
1 #sbs-git:slp/api/package-manager capi-appfw-package-manager 0.1.0 76739af2bfbeb46dc9db0cb3e044f880ddcb9440
2 Name:       capi-appfw-package-manager
3 Summary:    Package Manager API
4 Version: 0.0.22
5 Release:    1
6 Group:      TO_BE/FILLED_IN
7 License:    TO BE FILLED IN
8 Source0:    %{name}-%{version}.tar.gz
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(dlog)
11 BuildRequires:  pkgconfig(pkgmgr)
12 BuildRequires:  pkgconfig(pkgmgr-info)
13 BuildRequires:  pkgconfig(ail)
14 BuildRequires:  pkgconfig(vconf)
15 BuildRequires:  pkgconfig(aul)
16 BuildRequires:  pkgconfig(capi-base-common)
17 Requires(post): /sbin/ldconfig
18 Requires(postun): /sbin/ldconfig
19
20 %description
21 The Package Manager API provides functions to install, uninstall the package,
22 and also privides event listening function.
23
24 %package devel
25 Summary:  Package Manager API (Development)
26 Group:    TO_BE/FILLED_IN
27 Requires: %{name} = %{version}-%{release}
28
29 %description devel
30 The Package Manager API provides functions to install, uninstall the package,
31 and also privides event listening function. (DEV)
32
33
34 %prep
35 %setup -q
36
37
38 %build
39 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
40 cmake . -DCMAKE_INSTALL_PREFIX=/usr -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
41
42 make %{?jobs:-j%jobs}
43
44 %install
45 rm -rf %{buildroot}
46 %make_install
47
48 %post -p /sbin/ldconfig
49
50 %postun -p /sbin/ldconfig
51
52
53 %files
54 %manifest capi-appfw-package-manager.manifest
55 %{_libdir}/libcapi-appfw-package-manager.so.*
56 %{_bindir}/pkgmgr_tool
57
58 %files devel
59 %{_includedir}/appfw/package_manager.h
60 %{_includedir}/appfw/package_info.h
61 %{_libdir}/libcapi-appfw-package-manager.so
62 %{_libdir}/pkgconfig/*.pc
63
64