Git init
[framework/api/app-manager.git] / packaging / capi-appfw-app-manager.spec
1 Name:       capi-appfw-app-manager
2 Summary:    Application Manager API
3 Version:    0.0.1
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    TO BE FILLED IN
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(dlog)
10 BuildRequires:  pkgconfig(vconf)
11 BuildRequires:  pkgconfig(aul)
12 BuildRequires:  pkgconfig(ail)
13 BuildRequires:  pkgconfig(capi-base-common)
14 Requires(post): /sbin/ldconfig  
15 Requires(postun): /sbin/ldconfig
16
17 %description
18 The Application Manager API provides functions to get information about running applications.
19
20 %package devel
21 Summary:  Application Manager API (Development)
22 Group:    TO_BE/FILLED_IN
23 Requires: %{name} = %{version}-%{release}
24
25 %description devel
26 The Application Manager API provides functions to get information about running applications. (DEV)
27
28
29 %prep
30 %setup -q
31
32
33 %build
34 cmake . -DCMAKE_INSTALL_PREFIX=/usr
35
36
37 make %{?jobs:-j%jobs}
38
39 %install
40 rm -rf %{buildroot}
41 %make_install
42
43 %post -p /sbin/ldconfig
44
45 %postun -p /sbin/ldconfig
46
47
48 %files
49 %{_libdir}/libcapi-appfw-app-manager.so
50
51 %files devel
52 %{_includedir}/appfw/app_manager.h
53 %{_libdir}/pkgconfig/*.pc
54
55