cdb0b2612e6b972b242d871f5efe7b420662aa20
[platform/adaptation/camera-hal-v4l2.git] / packaging / camera-hal-v4l2.spec
1 %define enable_libv4l2 1
2
3 Name:       camera-hal-v4l2
4 Summary:    Tizen Camera Hal for V4L2
5 Version:    0.1.9
6 Release:    0
7 Group:      Multimedia/Libraries
8 License:    Apache-2.0
9 Source0:    %{name}-%{version}.tar.gz
10 Requires(post): /sbin/ldconfig
11 Requires(postun): /sbin/ldconfig
12 BuildRequires:  pkgconfig(glib-2.0)
13 BuildRequires:  pkgconfig(libtbm)
14 BuildRequires:  pkgconfig(dlog)
15 BuildRequires:  pkgconfig(hal-api-common)
16 BuildRequires:  pkgconfig(hal-api-camera)
17 %if 0%{?enable_libv4l2}
18 BuildRequires:  pkgconfig(libv4l2)
19 %endif
20
21 %description
22 Tizen Camera Hal for V4L2.
23
24
25 %prep
26 %setup -q
27
28
29 %build
30 ./autogen.sh
31 %configure \
32 %if 0%{?enable_libv4l2}
33         --enable-libv4l2\
34 %endif
35         --disable-static\
36         --libdir=%{_hal_libdir}
37 make %{?jobs:-j%jobs}
38
39 %install
40 %make_install
41 mkdir -p %{buildroot}%{_hal_licensedir}/%{name}
42 cp LICENSE.APLv2 %{buildroot}%{_hal_licensedir}/%{name}
43
44
45 %post
46 /sbin/ldconfig
47
48 %postun -p /sbin/ldconfig
49
50 %files
51 %manifest %{name}.manifest
52 %{_hal_licensedir}/%{name}/*
53 %defattr(-,root,root,-)
54 %{_hal_libdir}/*.so
55