Updating license in spec file
[apps/core/preloaded/call-setting.git] / packaging / call-setting.spec
1 Name:       call-setting
2 Summary:    Call Settings
3 Version:    0.2.82
4 Release:    1
5 Group:      Settings
6 License:    Flora Software License
7 Source0:    %{name}-%{version}.tar.gz
8 Source1001: packaging/call-setting.manifest 
9
10 BuildRequires: pkgconfig(appcore-efl)
11 BuildRequires: pkgconfig(elementary)
12 BuildRequires: pkgconfig(UI-idlecapture)
13 BuildRequires: pkgconfig(tapi)
14 BuildRequires: pkgconfig(utilX)
15 BuildRequires: pkgconfig(vconf)
16 BuildRequires: pkgconfig(eina)
17 BuildRequires: pkgconfig(ecore-imf)
18 BuildRequires: pkgconfig(ecore-x)
19 BuildRequires: pkgconfig(ecore-file)
20 BuildRequires: pkgconfig(dlog)
21 BuildRequires: pkgconfig(aul)
22 BuildRequires: pkgconfig(db-util)
23 BuildRequires: pkgconfig(ui-gadget)
24 BuildRequires: pkgconfig(contacts-service)
25 BuildRequires: pkgconfig(bundle)
26 BuildRequires: cmake
27 BuildRequires: gettext-tools
28 BuildRequires: libug-contacts-devel
29 BuildRequires: edje-bin, embryo-bin
30
31 Requires(post): /usr/bin/vconftool
32
33 %description
34 Call Settings.
35
36 %prep
37 %setup -q
38
39
40 %build
41 cp %{SOURCE1001} .
42 export LDFLAGS+="-Wl,--hash-style=both -Wl,--rpath=%{_prefix}/lib -Wl,--as-needed,--unresolved-symbols=ignore-in-shared-libs"
43 LDFLAGS="$LDFLAGS" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
44 make %{?jobs:-j%jobs}
45
46 %install
47 %make_install
48 mkdir -p %{buildroot}/opt/data/ug-setting-call
49
50 %find_lang ug-setting-call-efl
51
52 %post
53 vconftool set -t int db/ciss/show_my_number "1" -g 6514
54 vconftool set -t bool db/ciss/auto_reject "0" -g 6514
55 vconftool set -t bool db/ciss/auto_reject_unknown "0" -g 6514
56 vconftool set -t bool db/ciss/prefix_dial "0" -g 6514
57 vconftool set -t int db/ciss/prefix_dial_cnt "0" -g 6514
58 vconftool set -t string db/ciss/prefix_dial_num1 "" -g 6514
59 vconftool set -t string db/ciss/prefix_dial_num2 "" -g 6514
60 vconftool set -t string db/ciss/prefix_dial_num3 "" -g 6514
61 vconftool set -t string db/ciss/prefix_dial_num4 "" -g 6514
62 vconftool set -t string db/ciss/prefix_dial_num5 "" -g 6514
63 vconftool set -t bool db/ciss/reject_call_message "0" -g 6514
64 vconftool set -t int db/ciss/reject_call_message_cnt "4" -g 6514
65 vconftool set -t string db/ciss/user_create_message1 "I'll call you later" -g 6514
66 vconftool set -t string db/ciss/user_create_message2 "I'm in a meeting" -g 6514
67 vconftool set -t string db/ciss/user_create_message3 "I'm in class now" -g 6514
68 vconftool set -t string db/ciss/user_create_message4 "I'm driving" -g 6514
69 vconftool set -t string db/ciss/user_create_message5 "" -g 6514
70 vconftool set -t int db/ciss/answering_mode "0" -g 6514
71 vconftool set -t int db/ciss/answering_mode_time "1" -g 6514
72 vconftool set -t bool db/ciss/call_connect_tone "0" -g 6514
73 vconftool set -t bool db/ciss/minute_minder "0" -g 6514
74 vconftool set -t bool db/ciss/call_end_tone "0" -g 6514
75 vconftool set -t int db/ciss/alert_on_call "0" -g 6514
76 vconftool set -t string db/ciss/video_image_path "/opt/ug/res/images/ug-setting-call-efl/video_call_image_default.jpg" -g 6514
77 vconftool set -t bool db/ciss/own_video "0" -g 6514
78 vconftool set -t bool db/ciss/use_call_fail_options "0" -g 6514
79 vconftool set -t bool db/ciss/voice_auto_redial "0" -g 6514
80 vconftool set -t bool db/ciss/video_auto_redial "0" -g 6514
81 vconftool set -t int db/ciss/prefix_dial_value "1" -g 6514
82 vconftool set -t int db/ciss/reject_call_message_value "0" -g 6514
83 vconftool set -t bool db/ciss/call_diverting_indicator "0" -g 6514
84 vconftool set -t bool db/ciss/call_answering_key "0" -g 6514
85 vconftool set -t bool db/ciss/call_power_key_ends_call "0" -g 6514
86 chown -R 5000:5000 /opt/data/ug-setting-call
87
88 %files -f ug-setting-call-efl.lang
89 %manifest call-setting.manifest
90 /opt/data/ug-setting-call
91 /opt/ug/lib/libug-setting-call-efl.so
92 /opt/ug/res/edje/ug-setting-call-efl/call-setting-theme.edj
93 /opt/ug/res/edje/ug-setting-call-efl/call-setting.edj
94 /opt/ug/res/edje/ug-setting-call-efl/ug_effect.edj
95 /opt/ug/res/images/ug-setting-call-efl/*