Modificaiton for Multi user support.
[apps/core/preloaded/call-setting.git] / packaging / call-setting.spec
1 Name:       call-setting
2 Summary:    Call Settings
3 Version: 0.3.03
4 Release:    1
5 Group:      TBD
6 License:    Flora Software License
7 Source0:    %{name}-%{version}.tar.gz
8
9 BuildRequires: pkgconfig(appcore-efl)
10 BuildRequires: pkgconfig(elementary)
11 BuildRequires: pkgconfig(tapi)
12 BuildRequires: pkgconfig(utilX)
13 BuildRequires: pkgconfig(vconf)
14 BuildRequires: pkgconfig(eina)
15 BuildRequires: pkgconfig(ecore-imf)
16 BuildRequires: pkgconfig(ecore-x)
17 BuildRequires: pkgconfig(ecore-file)
18 BuildRequires: pkgconfig(dlog)
19 BuildRequires: pkgconfig(aul)
20 BuildRequires: pkgconfig(db-util)
21 BuildRequires: pkgconfig(contacts-service2)
22 BuildRequires: pkgconfig(msg-service)
23 BuildRequires: pkgconfig(capi-appfw-application)
24 BuildRequires: pkgconfig(capi-appfw-app-manager)
25 BuildRequires: pkgconfig(ui-gadget-1)
26 BuildRequires: libtzplatform-config-devel
27 BuildRequires: cmake
28 BuildRequires: gettext
29 BuildRequires: libug-contacts-devel
30 BuildRequires: edje-bin, embryo-bin
31
32 Requires(post): /usr/bin/vconftool
33
34 %description
35 Call Settings.
36
37 %prep
38 %setup -q
39
40 %build
41 export LDFLAGS+="-Wl,--hash-style=both -Wl,--rpath=%{_prefix}/lib -Wl,--as-needed,--unresolved-symbols=ignore-in-shared-libs"
42 LDFLAGS="$LDFLAGS" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
43 make %{?jobs:-j%jobs}
44
45 %install
46 %make_install
47 mkdir -p %{buildroot}/opt/usr/ug/ug-setting-call
48
49 %post
50 chgrp -R %{TZ_SYS_USER_GROUP} /opt/usr/ug/ug-setting-call
51
52 vconftool set -t int db/ciss/show_my_number "0" -g 6514 -f
53 vconftool set -t bool db/ciss/auto_reject "1" -g 6514 -f 
54 vconftool set -t bool db/ciss/auto_reject_unknown "0" -g 6514 -f
55 vconftool set -t bool db/ciss/prefix_dial "0" -g 6514 -f
56 vconftool set -t int db/ciss/prefix_dial_cnt "0" -g 6514 -f
57 vconftool set -t string db/ciss/prefix_dial_num1 "" -g 6514 -f
58 vconftool set -t string db/ciss/prefix_dial_num2 "" -g 6514 -f
59 vconftool set -t string db/ciss/prefix_dial_num3 "" -g 6514 -f
60 vconftool set -t string db/ciss/prefix_dial_num4 "" -g 6514 -f
61 vconftool set -t string db/ciss/prefix_dial_num5 "" -g 6514 -f
62 vconftool set -t int db/ciss/reject_call_message_cnt "5" -g 6514 -f
63 vconftool set -t string db/ciss/user_create_message1 "IDS_CST_BODY_IM_DRIVING" -g 6514 -f
64 vconftool set -t string db/ciss/user_create_message2 "IDS_CST_BODY_IM_IN_A_MEETING" -g 6514 -f
65 vconftool set -t string db/ciss/user_create_message3 "IDS_CST_BODY_IM_IN_CLASS_NOW" -g 6514 -f
66 vconftool set -t string db/ciss/user_create_message4 "IDS_CST_BODY_IM_AT_THE_CINEMA" -g 6514 -f
67 vconftool set -t string db/ciss/user_create_message5 "IDS_CST_BODY_SORRY_I_AM_BUSY_PLEASE_CALL_BACK_LATER" -g 6514 -f
68 vconftool set -t string db/ciss/user_create_message6 "" -g 6514 -f
69 vconftool set -t int db/ciss/answering_mode "0" -g 6514 -f
70 vconftool set -t int db/ciss/answering_mode_time "1" -g 6514 -f
71 vconftool set -t bool db/ciss/call_connect_tone "1" -g 6514 -f
72 vconftool set -t bool db/ciss/minute_minder "0" -g 6514 -f
73 vconftool set -t bool db/ciss/call_end_tone "1" -g 6514 -f
74 vconftool set -t int db/ciss/alert_on_call "1" -g 6514 -f
75 vconftool set -t string db/ciss/video_image_path "/usr/ug/res/images/ug-setting-call-efl/video_call_image_default.jpg" -g 6514 -f
76 vconftool set -t bool db/ciss/own_video "1" -g 6514 -f
77 vconftool set -t int db/ciss/prefix_dial_value "0" -g 6514 -f
78 vconftool set -t bool db/ciss/call_answering_key "0" -g 6514 -f
79 vconftool set -t bool db/ciss/call_power_key_ends_call "0" -g 6514 -f
80 vconftool set -t bool db/ciss/proximity_sensor "1" -g 6514 -f
81 vconftool set -t int db/ciss/outgoing_call_conditions "0" -g 6514 -f
82 vconftool set -t int db/ciss/outgoing_call_type "1" -g 6514 -f
83 vconftool set -t bool db/ciss/eye_contact "0" -g 6514 -f
84 vconftool set -t bool db/ciss/noise_reduction "1" -g 6514 -f
85 vconftool set -t int db/ciss/in_call_sound_eq "0" -g 6514 -f
86 vconftool set -t bool db/ciss/extra_vol "1" -g 6514 -f
87 vconftool set -t bool db/ciss/increase_ringtone "1" -g 6514 -f
88
89 %files
90 %manifest call-setting.manifest
91 %defattr(-,root,root,-)
92 %attr(-,inhouse,inhouse) /opt/usr/ug/ug-setting-call
93 /usr/ug/lib/libug-setting-call-efl.so
94 /usr/ug/res/edje/ug-setting-call-efl/call-setting-theme.edj
95 /usr/ug/res/edje/ug-setting-call-efl/call-setting.edj
96 /usr/ug/res/edje/ug-setting-call-efl/ug_effect.edj
97 /usr/ug/res/images/ug-setting-call-efl/*
98 /usr/ug/res/locale/*/LC_MESSAGES/ug-setting-call-efl.mo
99 /etc/smack/accesses2.d/ug.setting-call-efl.include