7fd48bf0fc8a99020edf9fa7eea12f93465e34dd
[apps/home/call-setting.git] / packaging / call-setting.spec
1 Name:       call-setting
2 Summary:    Call Settings
3 Version:    0.2.82
4 Release:    1
5 Group:      Settings
6 License:    Flora Software License
7 Source0:    %{name}-%{version}.tar.gz
8
9 BuildRequires: pkgconfig(appcore-efl)
10 BuildRequires: pkgconfig(elementary)
11 BuildRequires: pkgconfig(tapi)
12 BuildRequires: pkgconfig(utilX)
13 BuildRequires: pkgconfig(vconf)
14 BuildRequires: pkgconfig(eina)
15 BuildRequires: pkgconfig(ecore-imf)
16 BuildRequires: pkgconfig(ecore-x)
17 BuildRequires: pkgconfig(ecore-file)
18 BuildRequires: pkgconfig(dlog)
19 BuildRequires: pkgconfig(aul)
20 BuildRequires: pkgconfig(db-util)
21 BuildRequires: pkgconfig(ui-gadget)
22 BuildRequires: pkgconfig(contacts-service)
23 BuildRequires: pkgconfig(bundle)
24 BuildRequires: cmake
25 BuildRequires: gettext-tools
26 BuildRequires: libug-contacts-devel
27 BuildRequires: edje-bin, embryo-bin
28
29 Requires(post): /usr/bin/vconftool
30
31 %description
32 Call Settings.
33
34 %prep
35 %setup -q
36
37
38 %build
39 export LDFLAGS+="-Wl,--hash-style=both -Wl,--rpath=%{_prefix}/lib -Wl,--as-needed,--unresolved-symbols=ignore-in-shared-libs"
40 LDFLAGS="$LDFLAGS" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
41 make %{?jobs:-j%jobs}
42
43 %install
44 %make_install
45 mkdir -p %{buildroot}/opt/data/ug-setting-call
46
47 %find_lang ug-setting-call-efl
48
49 %post
50 vconftool set -t int db/ciss/show_my_number "1" -g 6514
51 vconftool set -t bool db/ciss/auto_reject "0" -g 6514
52 vconftool set -t bool db/ciss/auto_reject_unknown "0" -g 6514
53 vconftool set -t bool db/ciss/prefix_dial "0" -g 6514
54 vconftool set -t int db/ciss/prefix_dial_cnt "0" -g 6514
55 vconftool set -t string db/ciss/prefix_dial_num1 "" -g 6514
56 vconftool set -t string db/ciss/prefix_dial_num2 "" -g 6514
57 vconftool set -t string db/ciss/prefix_dial_num3 "" -g 6514
58 vconftool set -t string db/ciss/prefix_dial_num4 "" -g 6514
59 vconftool set -t string db/ciss/prefix_dial_num5 "" -g 6514
60 vconftool set -t bool db/ciss/reject_call_message "0" -g 6514
61 vconftool set -t int db/ciss/reject_call_message_cnt "4" -g 6514
62 vconftool set -t string db/ciss/user_create_message1 "I'll call you later" -g 6514
63 vconftool set -t string db/ciss/user_create_message2 "I'm in a meeting" -g 6514
64 vconftool set -t string db/ciss/user_create_message3 "I'm in class now" -g 6514
65 vconftool set -t string db/ciss/user_create_message4 "I'm driving" -g 6514
66 vconftool set -t string db/ciss/user_create_message5 "" -g 6514
67 vconftool set -t int db/ciss/answering_mode "0" -g 6514
68 vconftool set -t int db/ciss/answering_mode_time "1" -g 6514
69 vconftool set -t bool db/ciss/call_connect_tone "0" -g 6514
70 vconftool set -t bool db/ciss/minute_minder "0" -g 6514
71 vconftool set -t bool db/ciss/call_end_tone "0" -g 6514
72 vconftool set -t int db/ciss/alert_on_call "0" -g 6514
73 vconftool set -t string db/ciss/video_image_path "/opt/ug/res/images/ug-setting-call-efl/video_call_image_default.jpg" -g 6514
74 vconftool set -t bool db/ciss/own_video "0" -g 6514
75 vconftool set -t bool db/ciss/use_call_fail_options "0" -g 6514
76 vconftool set -t bool db/ciss/voice_auto_redial "0" -g 6514
77 vconftool set -t bool db/ciss/video_auto_redial "0" -g 6514
78 vconftool set -t int db/ciss/prefix_dial_value "1" -g 6514
79 vconftool set -t int db/ciss/reject_call_message_value "0" -g 6514
80 vconftool set -t bool db/ciss/call_diverting_indicator "0" -g 6514
81 vconftool set -t bool db/ciss/call_answering_key "0" -g 6514
82 vconftool set -t bool db/ciss/call_power_key_ends_call "0" -g 6514
83 chown -R 5000:5000 /opt/data/ug-setting-call
84
85 %files -f ug-setting-call-efl.lang
86 /opt/data/ug-setting-call
87 /opt/ug/lib/libug-setting-call-efl.so
88 /opt/ug/res/edje/ug-setting-call-efl/call-setting-theme.edj
89 /opt/ug/res/edje/ug-setting-call-efl/call-setting.edj
90 /opt/ug/res/edje/ug-setting-call-efl/ug_effect.edj
91 /opt/ug/res/images/ug-setting-call-efl/*