2012/08/21: tizen 2.0 beta
[apps/home/call-setting.git] / packaging / call-setting.spec
1 Name:       call-setting
2 Summary:    Call Settings
3 Version: 0.2.104
4 Release:    1
5 Group:      TBD
6 License:    Flora Software License 
7 Source0:    %{name}-%{version}.tar.gz
8
9 BuildRequires: pkgconfig(appcore-efl)
10 BuildRequires: pkgconfig(elementary)
11 BuildRequires: pkgconfig(tapi)
12 BuildRequires: pkgconfig(utilX)
13 BuildRequires: pkgconfig(vconf)
14 BuildRequires: pkgconfig(eina)
15 BuildRequires: pkgconfig(ecore-imf)
16 BuildRequires: pkgconfig(ecore-x)
17 BuildRequires: pkgconfig(ecore-file)
18 BuildRequires: pkgconfig(dlog)
19 BuildRequires: pkgconfig(aul)
20 BuildRequires: pkgconfig(db-util)
21 BuildRequires: pkgconfig(contacts-service)
22 BuildRequires: pkgconfig(phone-misc)
23 BuildRequires: pkgconfig(msg-service)
24 BuildRequires: pkgconfig(capi-appfw-application)
25 BuildRequires: pkgconfig(capi-appfw-app-manager)
26 BuildRequires: pkgconfig(ui-gadget-1)
27 BuildRequires: cmake
28 BuildRequires: gettext
29 BuildRequires: libug-contacts-devel
30 BuildRequires: edje-bin, embryo-bin
31
32 Requires(post): /usr/bin/vconftool
33
34 %description
35 Call Settings.
36
37 %prep
38 %setup -q
39
40
41 %build
42 export LDFLAGS+="-Wl,--hash-style=both -Wl,--rpath=%{_prefix}/lib -Wl,--as-needed,--unresolved-symbols=ignore-in-shared-libs"
43 LDFLAGS="$LDFLAGS" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
44 make %{?jobs:-j%jobs}
45
46 %install
47 %make_install
48 mkdir -p %{buildroot}/opt/data/ug-setting-call
49
50 %post
51 chown -R 5000:5000 /opt/data/ug-setting-call
52
53 vconftool set -t int db/ciss/show_my_number "0" -g 6514
54 vconftool set -t bool db/ciss/auto_reject "1" -g 6514
55 vconftool set -t bool db/ciss/auto_reject_unknown "0" -g 6514
56 vconftool set -t bool db/ciss/prefix_dial "0" -g 6514
57 vconftool set -t int db/ciss/prefix_dial_cnt "0" -g 6514
58 vconftool set -t string db/ciss/prefix_dial_num1 "" -g 6514
59 vconftool set -t string db/ciss/prefix_dial_num2 "" -g 6514
60 vconftool set -t string db/ciss/prefix_dial_num3 "" -g 6514
61 vconftool set -t string db/ciss/prefix_dial_num4 "" -g 6514
62 vconftool set -t string db/ciss/prefix_dial_num5 "" -g 6514
63 vconftool set -t int db/ciss/reject_call_message_cnt "5" -g 6514
64 vconftool set -t string db/ciss/user_create_message1 "IDS_CST_BODY_IM_DRIVING" -g 6514
65 vconftool set -t string db/ciss/user_create_message2 "IDS_CST_BODY_IM_IN_A_MEETING" -g 6514
66 vconftool set -t string db/ciss/user_create_message3 "IDS_CST_BODY_IM_IN_CLASS_NOW" -g 6514
67 vconftool set -t string db/ciss/user_create_message4 "IDS_CST_BODY_IM_AT_THE_CINEMA" -g 6514
68 vconftool set -t string db/ciss/user_create_message5 "IDS_CST_BODY_SORRY_I_AM_BUSY_PLEASE_CALL_BACK_LATER" -g 6514
69 vconftool set -t string db/ciss/user_create_message6 "" -g 6514
70 vconftool set -t int db/ciss/answering_mode "0" -g 6514
71 vconftool set -t int db/ciss/answering_mode_time "1" -g 6514
72 vconftool set -t bool db/ciss/call_connect_tone "1" -g 6514
73 vconftool set -t bool db/ciss/minute_minder "0" -g 6514
74 vconftool set -t bool db/ciss/call_end_tone "1" -g 6514
75 vconftool set -t int db/ciss/alert_on_call "1" -g 6514
76 vconftool set -t string db/ciss/video_image_path "/opt/ug/res/images/ug-setting-call-efl/video_call_image_default.jpg" -g 6514
77 vconftool set -t bool db/ciss/own_video "1" -g 6514
78 vconftool set -t int db/ciss/prefix_dial_value "0" -g 6514
79 vconftool set -t bool db/ciss/call_answering_key "0" -g 6514
80 vconftool set -t bool db/ciss/call_power_key_ends_call "0" -g 6514
81 vconftool set -t bool db/ciss/proximity_sensor "1" -g 6514
82 vconftool set -t int db/ciss/outgoing_call_conditions "0" -g 6514
83 vconftool set -t int db/ciss/outgoing_call_type "1" -g 6514
84 vconftool set -t bool db/ciss/eye_contact "0" -g 6514
85 vconftool set -t bool db/ciss/noise_reduction "1" -g 6514
86 vconftool set -t int db/ciss/in_call_sound_eq "0" -g 6514
87 vconftool set -t bool db/ciss/extra_vol "1" -g 6514
88 vconftool set -t bool db/ciss/increase_ringtone "1" -g 6514
89
90 %files
91 %defattr(-,root,root,-)
92 %attr(-,inhouse,inhouse) /opt/data/ug-setting-call
93 /opt/ug/lib/libug-setting-call-efl.so
94 /opt/ug/res/edje/ug-setting-call-efl/call-setting-theme.edj
95 /opt/ug/res/edje/ug-setting-call-efl/call-setting.edj
96 /opt/ug/res/edje/ug-setting-call-efl/ug_effect.edj
97 /opt/ug/res/images/ug-setting-call-efl/*
98 /opt/ug/res/locale/*/LC_MESSAGES/ug-setting-call-efl.mo