1320141262d60cbc6d3278dc1611480ae665debb
[framework/security/ca-certificates.git] / packaging / ca-certificates.spec
1 Name:       ca-certificates
2 Summary:    Install basic certificates which be used applications
3 Version: 0.0.2
4 Release:    2
5 Group:      System/Files
6 License:    None
7 Source0:    %{name}-%{version}.tar.gz
8
9 %if "%{_repository}" == "wearable"
10
11 %description
12 install basic certificates which be used applications
13
14 %prep
15 %setup -q
16
17 %build
18 echo "########################################"
19 echo "TIZEN_PROFILE_WEARABLE"
20 echo "########################################"
21 cp -R modules_wearable/* .
22
23 %install
24 rm -rf %{buildroot}
25 mkdir -p %{buildroot}/usr/share/license
26 cp LICENSE.APLv2 %{buildroot}/usr/share/license/%{name}
27
28 mkdir -p %{buildroot}/opt/etc/ssl
29 cp -arf certs %{buildroot}/opt/etc/ssl/
30
31 %files
32 %defattr(-,root,root,-)
33 /opt/etc/ssl/certs/*
34 %{_datadir}/license/%{name}
35
36
37 %else
38
39 %description
40 install basic certificates which be used applications
41
42 %prep
43 %setup -q
44
45 %build
46 echo "########################################"
47 echo "TIZEN_PROFILE_MOBILE"
48 echo "########################################"
49 cp -R modules_mobile/* .
50
51 %install
52 rm -rf %{buildroot}
53
54 mkdir -p %{buildroot}/opt/etc/ssl
55 cp -arf certs %{buildroot}/opt/etc/ssl/
56
57 %files
58 %defattr(-,root,root,-)
59 /opt/etc/ssl/certs/*
60
61
62
63 %endif