Migrate to openssl 1.1
[platform/core/security/ca-certificates-tizen-ext.git] / packaging / ca-certificates-tizen-ext.spec
1 Name:          ca-certificates-tizen-ext
2 Summary:       Tizen product specific CA certificate installation.
3 Version:       0.1.0
4 Release:       0
5 Group:         Security/Certificate Management
6 URL:           http://www.tizen.org
7 License:       Apache-2.0
8 Source:        %{name}-%{version}.tar.gz
9 Source1001:    %{name}.manifest
10 BuildRequires: cmake
11 BuildRequires: openssl1.1
12 BuildRequires: pkgconfig(libtzplatform-config)
13
14 %description
15 Used for the installation of Tizen-product specific CA certificates.
16 These certificates must be replaced with ones for each product.
17
18
19 %define ro_data_dir     %{?TZ_SYS_RO_SHARE:%TZ_SYS_RO_SHARE}%{!?TZ_SYS_RO_SHARE:%_datadir}
20 %define tizen_dir       %{ro_data_dir}/ca-certificates/tizen
21 %define fingerprint_dir %{ro_data_dir}/ca-certificates/fingerprint
22 %define ro_etc_dir %{?TZ_SYS_RO_ETC:%TZ_SYS_RO_ETC}%{!?TZ_SYS_RO_ETC:%_sysconfdir}
23
24 %prep
25 %setup -q
26 cp %{SOURCE1001} .
27
28 %build
29
30 # define build architecture
31 %ifarch %{ix86}
32     echo "release emulator mode"
33     %define REL_MODE emul
34 %else
35     %if 0%{?tizen_build_devel_mode}
36         echo "release engineering mode"
37         %define REL_MODE eng
38     %else
39         echo "release user mode"
40         %define REL_MODE usr
41     %endif
42 %endif
43
44 %cmake . -DRELMODE=%{REL_MODE} \
45          -DTIZEN_DIR=%{tizen_dir} \
46          -DFINGERPRINT_DIR=%{fingerprint_dir} \
47
48 make %{?_smp_mflags}
49
50 %install
51 %make_install
52
53 mkdir -p %{buildroot}%{ro_etc_dir}/rpm
54
55
56 %files
57 %defattr(-,root,root,-)
58 %manifest %{name}.manifest
59 %license LICENSE
60 #%{tizen_dir}/*
61 %{fingerprint_dir}/*