packaging: Bump to 1.10.0
[platform/upstream/c-ares.git] / packaging / c-ares.spec
1 Name:           c-ares
2 Version:        1.10.0
3 Release:        0
4 License:        MIT
5 Summary:        Library for asynchronous name resolves
6 Group:          Development/Libraries/C and C++
7 Source:         http://daniel.haxx.se/projects/c-ares/%{name}-%{version}.tar.bz2
8 Source2:        baselibs.conf
9 Source1001:     c-ares.manifest
10 BuildRequires:  pkg-config
11 BuildRequires:  libtool
12 Url:            http://daniel.haxx.se/projects/c-ares
13
14 %description
15 c-ares is a C library that performs DNS requests and name resolves
16 asynchronously. c-ares is a fork of the library named 'ares', written
17 by Greg Hudson at MIT.
18
19 %package -n libcares
20 Summary:        Library for asynchronous name resolves
21 Group:          Development/Libraries/C and C++
22
23 %description -n libcares
24 c-ares is a C library that performs DNS requests and name resolves
25 asynchronously. c-ares is a fork of the library named 'ares', written
26 by Greg Hudson at MIT.
27
28 %package -n libcares-devel
29 Summary:        Library for asynchronous name resolves
30 Group:          Development/Libraries/C and C++
31 Requires:       libcares = %{version}
32 Requires:       glibc-devel
33
34 %description -n libcares-devel
35 c-ares is a C library that performs DNS requests and name resolves
36 asynchronously. c-ares is a fork of the library named 'ares', written
37 by Greg Hudson at MIT.
38
39 %prep
40 %setup -q -n %{name}-%{version}
41 cp %{SOURCE1001} .
42
43 %build
44 autoreconf -fiv
45 %configure --enable-symbol-hiding --enable-nonblocking --enable-shared --disable-static --with-pic
46 sed -i -e 's@-g0@-g@g' Makefile
47 make %{?_smp_mflags}
48
49 %install
50 %make_install
51
52 %post -p /sbin/ldconfig -n libcares
53
54 %postun -p /sbin/ldconfig -n libcares
55
56 %files -n libcares
57 %manifest %{name}.manifest
58 %defattr(-,root,root)
59 %{_libdir}/libcares.so.2*
60
61 %files -n libcares-devel
62 %manifest %{name}.manifest
63 %defattr(-,root,root)
64 %{_libdir}/libcares.so
65 %{_includedir}/*.h
66 %{_mandir}/man3/ares_*
67 %{_libdir}/pkgconfig/libcares.pc
68
69 %changelog