add packaging
[platform/upstream/busybox.git] / packaging / busybox.spec
1 Name:           busybox
2 Version:        1.20.2
3 Release:        0
4 License:        GPL-2.0+
5 Summary:        The Swiss Army Knife of Embedded Linux
6 Url:            http://www.busybox.net/
7 Group:          System/Base
8 Source:         http://busybox.net/downloads/%{name}-%{version}.tar.bz2
9 Source2:        busybox.tizen.config
10
11 %description
12 BusyBox combines tiny versions of many common UNIX utilities into a
13 small single executable. It provides minimalist replacements for most
14 of the utilities usually found in fileutils, shellutils, findutils,
15 textutils, grep, gzip, tar, and more. BusyBox provides a fairly
16 complete POSIX environment for any small or embedded system. The
17 utilities in BusyBox generally have fewer options than their
18 full-featured GNU cousins. The options that are included provide the
19 expected functionality and behave very much like their GNU
20 counterparts.
21
22 %prep
23 %setup -q
24 cp -a %{SOURCE2} .config
25
26 %build
27 export VERBOSE=-v
28 export BUILD_VERBOSE=2
29 export CFLAGS="%{optflags} -fno-strict-aliasing"
30 export CC="gcc"
31 export HOSTCC=gcc
32 make -e oldconfig
33 make -e %{?_smp_mflags}
34 make -e doc busybox.links %{?_smp_mflags}
35
36 %install
37 install -d %{buildroot}%{_prefix}/bin
38 install -d %{buildroot}%{_datadir}/busybox
39 install busybox.links %{buildroot}%{_datadir}/busybox
40 install applets/install.sh %{buildroot}%{_bindir}/busybox.install
41 install busybox %{buildroot}%{_prefix}/bin
42
43 %files
44 %defattr(-,root,root)
45 %license LICENSE
46 %{_bindir}/busybox
47 %{_bindir}/busybox.install
48 %dir %{_datadir}/busybox
49 %config %{_datadir}/busybox/busybox.links
50
51 %changelog