Packaging: clean spec file
[platform/core/base/bundle.git] / packaging / bundle.spec
1 Name:       bundle
2 Summary:    String key-val dictionary ADT
3 Version:    0.1.31
4 Release:    0
5 Group:      System/Libraries
6 License:    Apache-2.0
7 Source0:        bundle-%{version}.tar.gz
8 Source1001:     bundle.manifest
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(glib-2.0)
11 BuildRequires:  pkgconfig(dlog)
12 %description
13 Simple string key-val dictionary ADT
14
15 %package devel
16 Summary:    String key-val dictionary ADT (devel)
17 Group:      Development/Libraries
18 Requires:   %{name} = %{version}-%{release}
19
20 %description devel
21 Simple string key-val dictionary ADT (devel)
22
23
24 %prep
25 %setup -q -n %{name}-%{version}
26 cp %{SOURCE1001} .
27
28 %build
29 %cmake .
30 %__make %{?_smp_mflags}
31
32 %install
33 %make_install
34
35 %post -p /sbin/ldconfig
36
37 %postun -p /sbin/ldconfig
38
39
40 %files
41 %manifest %{name}.manifest
42 %defattr(-,root,root,-)
43 %{_libdir}/libbundle.so.*
44 %license LICENSE
45
46 %files devel
47 %manifest %{name}.manifest
48 %defattr(-,root,root,-)
49 %{_includedir}/bundle.h
50 %{_includedir}/SLP_bundle_PG.h
51 %{_libdir}/pkgconfig/bundle.pc
52 %{_libdir}/libbundle.so