Add license file
[platform/core/base/bundle.git] / packaging / bundle.spec
1 Name:       bundle
2 Summary:    String key-val dictionary ADT
3 Version:    0.1.31
4 Release:    1
5 Group:      System/Libraries
6 License:    Apache License, Version 2.0
7 Source0:    bundle-%{version}.tar.gz
8 Source1001:     bundle.manifest
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(glib-2.0)
11 BuildRequires:  pkgconfig(dlog)
12 %description
13 Simple string key-val dictionary ADT
14
15 %package devel
16 Summary:    String key-val dictionary ADT (devel)
17 Group:      Development/Libraries
18 Requires:   %{name} = %{version}-%{release}
19
20 %description devel
21 Simple string key-val dictionary ADT (devel)
22
23
24 %prep
25 %setup -q -n %{name}-%{version}
26 cp %{SOURCE1001} .
27
28
29 %build
30 %cmake .
31 make %{?jobs:-j%jobs}
32
33 %install
34 %make_install
35
36 mkdir -p %{buildroot}/usr/share/license
37 cp LICENSE %{buildroot}/usr/share/license/%{name}
38
39 %post -p /sbin/ldconfig
40
41 %postun -p /sbin/ldconfig
42
43
44 %files
45 %manifest %{name}.manifest
46 %defattr(-,root,root,-)
47 %{_libdir}/libbundle.so.*
48 /usr/share/license/%{name}
49
50
51 %files devel
52 %manifest %{name}.manifest
53 %defattr(-,root,root,-)
54 %{_includedir}/bundle.h
55 %{_includedir}/SLP_bundle_PG.h
56 %{_libdir}/pkgconfig/bundle.pc
57 %{_libdir}/libbundle.so
58