merge with master
[platform/core/base/bundle.git] / packaging / bundle.spec
1 Name:       bundle
2 Summary:    String key-val dictionary ADT
3 Version:    0.1.30
4 Release:    1
5 Group:      System/Libraries
6 License:    Apache License, Version 2.0
7 Source0:    bundle-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(glib-2.0)
10 BuildRequires:  pkgconfig(dlog)
11 %description
12 Simple string key-val dictionary ADT
13
14 %package devel
15 Summary:    String key-val dictionary ADT (devel)
16 Group:      Development/Libraries
17 Requires:   %{name} = %{version}-%{release}
18
19 %description devel
20 Simple string key-val dictionary ADT (devel)
21
22
23 %prep
24 %setup -q -n %{name}-%{version}
25
26
27 %build
28 %cmake .
29 make %{?jobs:-j%jobs}
30
31 %install
32 %make_install
33
34 %post -p /sbin/ldconfig
35
36 %postun -p /sbin/ldconfig
37
38
39 %files
40 %manifest bundle.manifest
41 %defattr(-,root,root,-)
42 %{_libdir}/libbundle.so.*
43
44
45 %files devel
46 %defattr(-,root,root,-)
47 %{_includedir}/bundle.h
48 %{_includedir}/SLP_bundle_PG.h
49 %{_libdir}/pkgconfig/bundle.pc
50 %{_libdir}/libbundle.so
51