tizen 2.3.1 release
[framework/base/bundle.git] / packaging / bundle.spec
1 Name:       bundle
2 Summary:    String key-val dictionary ADT
3 Version:    0.1.36
4 Release:    1
5 Group:      System/Libraries
6 License:    Apache-2.0
7 Source0:    bundle-%{version}.tar.gz
8 Requires(post): /sbin/ldconfig
9 Requires(postun): /sbin/ldconfig
10 BuildRequires:  cmake
11 BuildRequires:  pkgconfig(glib-2.0)
12 BuildRequires:  pkgconfig(dlog)
13 BuildRequires:  pkgconfig(capi-base-common)
14
15 %description
16 Simple string key-val dictionary ADT
17
18 %package devel
19 Summary:    String key-val dictionary ADT (devel)
20 Group:      Development/Libraries
21 Requires:   %{name} = %{version}-%{release}
22
23 %description devel
24 Simple string key-val dictionary ADT (devel)
25
26 %prep
27 %setup -q -n %{name}-%{version}
28
29 %build
30 export CFLAGS="$CFLAGS -Wall -Werror -Wno-unused-function"
31 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
32
33 make %{?jobs:-j%jobs}
34
35 %install
36 rm -rf %{buildroot}
37 %make_install
38
39 mkdir -p %{buildroot}/usr/share/license
40 cp LICENSE %{buildroot}/usr/share/license/%{name}
41
42 %post -p /sbin/ldconfig
43
44 %postun -p /sbin/ldconfig
45
46 %files
47 %manifest bundle.manifest
48 %defattr(-,root,root,-)
49 %{_libdir}/libbundle.so.*
50 /usr/share/license/%{name}
51
52 %files devel
53 %defattr(-,root,root,-)
54 %{_includedir}/bundle.h
55 %{_includedir}/SLP_bundle_PG.h
56 %{_libdir}/pkgconfig/bundle.pc
57 %{_libdir}/libbundle.so