b9d743beb44a9cd74fc4980c0d804d50046caf0e
[framework/base/bundle.git] / packaging / bundle.spec
1
2 Name:       bundle
3 Summary:    String key-val dictionary ADT
4 Version:    0.1.22
5 Release:    1
6 Group:      System/Libraries
7 License:    Apache License, Version 2.0
8 Source0:    bundle-%{version}.tar.gz
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11 BuildRequires:  cmake
12 BuildRequires:  pkgconfig(glib-2.0)
13 BuildRequires:  pkgconfig(dlog)
14
15
16 %description
17 Simple string key-val dictionary ADT
18
19
20
21 %package devel
22 Summary:    String key-val dictionary ADT (devel)
23 Group:      Development/Libraries
24 Requires:   %{name} = %{version}-%{release}
25
26 %description devel
27 Simple string key-val dictionary ADT (devel)
28
29
30 %prep
31 %setup -q -n %{name}-%{version}
32
33
34 %build
35 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
36
37
38 make %{?jobs:-j%jobs}
39
40 %install
41 rm -rf %{buildroot}
42 %make_install
43
44
45
46
47 %post -p /sbin/ldconfig
48
49 %postun -p /sbin/ldconfig
50
51
52
53
54
55 %files
56 %defattr(-,root,root,-)
57 %{_libdir}/libbundle.so.*
58
59
60 %files devel
61 %defattr(-,root,root,-)
62 %{_includedir}/bundle.h
63 %{_includedir}/SLP_bundle_PG.h
64 %{_libdir}/pkgconfig/bundle.pc
65 %{_libdir}/libbundle.so
66