Get version info from .spec file
[platform/core/base/bundle.git] / packaging / bundle.spec
1 Name:       bundle
2 Summary:    String key-val dictionary ADT
3 Version:    0.1.31
4 Release:    0
5 Group:      System/Libraries
6 License:    Apache-2.0
7 Source0:        bundle-%{version}.tar.gz
8 Source1001:     bundle.manifest
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(glib-2.0)
11 BuildRequires:  pkgconfig(dlog)
12 BuildRequires:  pkgconfig(capi-base-common)
13 %description
14 Simple string key-val dictionary ADT
15
16 %package devel
17 Summary:    String key-val dictionary ADT (devel)
18 Group:      Development/Libraries
19 Requires:   %{name} = %{version}-%{release}
20
21 %description devel
22 Simple string key-val dictionary ADT (devel)
23
24
25 %prep
26 %setup -q -n %{name}-%{version}
27 cp %{SOURCE1001} .
28
29 %build
30 %cmake -DVERSION=%{version} .
31 %__make %{?_smp_mflags}
32
33 %install
34 %make_install
35
36 %post -p /sbin/ldconfig
37
38 %postun -p /sbin/ldconfig
39
40
41 %files
42 %manifest %{name}.manifest
43 %defattr(-,root,root,-)
44 %{_libdir}/libbundle.so.*
45 %license LICENSE
46
47 %files devel
48 %manifest %{name}.manifest
49 %defattr(-,root,root,-)
50 %{_includedir}/bundle.h
51 %{_includedir}/SLP_bundle_PG.h
52 %{_libdir}/pkgconfig/bundle.pc
53 %{_libdir}/libbundle.so